Wiki Ubuntu-it

Indice
Partecipa
FAQ
Wiki Blog
------------------
Ubuntu-it.org
Forum
Chiedi
Chat
Cerca
Planet
  • Immutable Page
  • Info
  • Attachments


Guida verificata con Ubuntu: 20.04 22.04

Problemi in questa pagina? Segnalali in questa discussione

Introduzione

Atom è un editor di testo avanzato, basato su Electron e creato da GitHub.

Ha funzionalità evolute (autocompletamento, multi selezione del testo, mappa del testo ecc.), in buona parte simili a quelle di Sublime Text. Può inoltre essere arricchito di funzionalità attraverso numerose estensioni rese disponibili dalla comunità degli sviluppatori.

Lo sviluppo ufficiale dell'editor è cessato. A seguito di ciò sono scaturiti due progetti per continuarne lo sviluppo: l'editor Atomic e l'editor Pulsar. Per maggiori informazioni sull'editor Pulsar consultare questa pagina.

Atom richiede molte risorse alla memoria RAM, pertanto il suo utilizzo su computer poco prestanti potrebbe non essere ottimale.

Di seguito verranno riportati tra parentesi i nomi dei menù in italiano.

Installazione

Sono disponibili tre modalità d'installazione: tramite pacchetto .deb, in modalità portable o tramite pacchetto snap.

Da pacchetto deb

Si può ancora scaricare e installare l'ultima versione dell'editor dal suo archivio pubblico su GitHub.

  1. Scaricare il pacchetto in formato .deb digitando nel terminale il comando:

    wget https://github.com/atom/atom/releases/download/v1.61.0-beta0/atom-amd64.deb
  2. Installare il pacchetto dal terminale col comando:

    sudo apt install ./atom-amd64.deb
  3. Al termine della procedura, sarà possibile avviare Atom.

Modalità portable

In questo modalità all'occorrenza è possibile rimuovere Atom semplicemente eliminando la cartella dove è stato estratto.

  1. Scaricare l'archivio in formato .deb digitando nel terminale il comando:

    wget https://github.com/atom/atom/releases/download/v1.61.0-beta0/atom-amd64.tar.gz
  2. Estrarre il contenuto dell'archivio .tar.gz nella propria Home.

  3. Spostarsi nella cartella atom-<numero versione>-amd64.

  4. Avviare il programma digitando il comando:

    ./atom

In alternativa aprire il file manager, selezionare la cartella atom-<numero versione>-amd64 nella Home, e fare clic sul file atom.

L'icona specifica di atom, per personalizzare e distinguere la cartella atom dalle altre, è disponibile nella cartella ~/atom/resources/.

Pacchetto snap

Per installare il programma da pacchetto snap digitare nel terminale il comando:

sudo snap install atom --classic

Per ulteriori informazioni leggere questa pagina.

Aggiornamento

Essendo cessato lo sviluppo non è più possibile aggiornarlo.

Impostazioni

Dal menù Edit → Preferences... (Modifica → Preferenze) sarà possibile gestire i vari aspetti della configurazione dell'editor di testo:

  • configurazioni;
  • scorciatoie da tastiera;
  • pacchetti installati;
  • temi;
  • ricerca di nuovi pacchetti.

Localizzazione

È possibile impostare una lingua differente tramite l'installazione del pacchetto atom-i18n, omnicomprensivo di molte lingue. Per la lista delle lingue disponibili consultare questa questa pagina.

  1. Selezionare il menù Edit → Preferences.

  2. Selezionare la scheda Settings → +Install.

  3. Nel menù a tendina Language digitare atom-i18n.

  4. Premere su Install per scaricare ed eseguire l'installazione.

  5. Premere su Settings e scorrere verso il basso alla sezione Language.

  6. Selezionare nella casella di ricerca la lingua desiderata e accettare il riavvio dell'editor per caricare la lingua.

Terminale integrato

Sono disponibili all'installazione svariati terminali integrati, con caratteristiche diverse per adattarsi a specifiche necessità.

  1. Selezionare il menù Modifica → Preferenze.

  2. Selezionare la scheda Impostazioni → +Installa.

  3. Nella barra ricerca digitare terminal.

  4. Scorrere la lista e fare clic sul tasto Installa di quello desiderato.

  5. Terminata l'installazione fare clic sul tasto Impostazioni per personalizzare alle proprie necessità il funzionamento.

Scorciatoie da tastiera

Segue un elenco di alcune utili scorciatoie da tastiera:

Sequenza tasti

Funzionalità

Ctrl+

Accedere alle preferenze

Ctrl+O

Aprire file

Alt+shift+↓

Selezionare una colonna

Ctrl+D

Selezionare stringhe identiche a quella già selezionata

Ctrl+/

Commentare il codice

Ctrl+Alt+.

Completamento parentesi

Ctrl+j

Unire linee

Ctrl+m

Evidenziare parentesi/tag

Ctrl+Alt+m

Cursore fra parentesi/tag

Ctrl+l

Selezionare linea

Ctrl+Shift+d

Duplicare linea

Ctrl+↓

Muovere linea giù

Ctrl+↑

Muovere linea su

Ctrl+Enter

Inserire una nuova linea

Per aggiungere/modificare/eliminare le scorciatoie da tastiera seguire il menù Edit → Preferences → Keybindings (Modifica → Preferenze → Mappa Tasti).

Ulteriori risorse


CategoryProgrammazione CategoryProduttivita