Wiki Ubuntu-it

Indice
Partecipa
FAQ
Wiki Blog
------------------
Ubuntu-it.org
Forum
Chiedi
Chat
Cerca
Planet
  • Immutable Page
  • Info
  • Attachments


Guida verificata con Ubuntu: 20.04 22.04

Problemi in questa pagina? Segnalali in questa discussione

Introduzione

Pulsar è un editor di testo avanzato, basato su Electron, creato da Pulsar come continuazione dello sviluppo dell'editor Atom, il cui sviluppo è ufficialmente cessato.

Ha funzionalità evolute (autocompletamento, multi selezione del testo, mappa del testo ecc.), in buona parte simili a quelle di Sublime Text. Può inoltre essere arricchito di funzionalità attraverso numerose estensioni rese disponibili dalla comunità.

Da notare che Pulsar richiede elevate risorse computazionali, pertanto si potrebbero verificare rallentamenti e/o malfunzionamenti nel suo utilizzo su computer datati o con poche risorse hardware, tipo memoria insufficiente o cpu con prestazioni scarse.

Al momento non esiste un rilascio stabile dell'editor, seppur sia usabile senza problemi. L'editor è sotto costante sviluppo, con continui nuovi rilasci di versione. La versione resa disponibile al momento dello scaricamento, è quella considerata stabile dagli sviluppatori.

Nel seguito tra parentesi verranno riportati i nomi dei menù in italiano.

Installazione

Sono disponibili tre modalità d'installazione: tramite pacchetto .deb, in modalità portable o tramite file eseguibile .appimage.

Da pacchetto deb

  1. Scaricare il pacchetto in formato .deb da questo link.

  2. Installare il file .deb scaricato.

  3. Al termine della procedura, sarà possibile avviare Pulsar.

Se si desidera installare la versione beta di sviluppo, scaricare il pacchetto in formato .deb da questo link. Si sconsiglia di utilizzare le versioni beta per scopi diversi dal provare nuove funzionalità software.

Aggiornamento

Installato in questa modalità non saranno attivi gli aggiornamenti di versione, pertanto bisognerà scaricare nuovamente e installare la nuova versione del pacchetto pulsar_<numero versione>_amd64.deb, quando disponibile.

Da AppImage

  1. In Ubuntu 22.04 e successivi installare il pacchetto libfuse2.

  2. Scaricare il file appimage da questo link.

  3. Procedere con la sua installazione.

In caso di funzionamento irregolare, avviare il file da terminale posponendo l'opzione «--no-sandbox».

Modalità portable

In questo modalità è possibile rimuovere Pulsar all'occorrenza semplicemente eliminando la cartella dove è stato estratto, senza lasciare tracce nel sistema.

  1. Scaricare l'archivio in formato tar.gz da questo link.

  2. Estrarre il contenuto dell'archivio nella propria Home.

  3. Spostarsi nella cartella pulsar-<numero versione>.

  4. Avviare il programma digitando il comando nel terminale:

    ./pulsar

In alternativa aprire il file manager, selezionare la cartella pulsar-<numero versione> nella Home e fare clic sul file pulsar.

Per personalizzare e distinguere la cartella pulsar-<numero versione> dalle altre, è disponibile l'icona specifica del programma nella cartella ~/pulsar-<numero versione>/resources/.

Il nome della cartella ~/pulsar-<numero versione>/resources/ non sarà aggiornato quando il programma verrà aggiornato.

Aggiornamento

Da predefinito è impostata l'opzione per l'aggiornamento automatico. Se si preferisce farlo in modalità manuale occorre eseguire i seguenti passaggi:

  1. Aprire le impostazioni tramite il menù Edit → Preferences...(Modifica → Preferenze).

  2. Selezionare la scheda Base (Base).

  3. Rimuovere la spunta alla voce Automatically Update (Aggiorna automaticamente).

  4. Selezionare la scheda Updates (Aggiornamenti).

  5. Fare clic su Check for Updates (Controlla Aggiornamenti).

Impostazioni

Dal menù Edit → Preferences... (Modifica → Preferenze) sarà possibile gestire i vari aspetti della configurazione dell'editor di testo:

  • configurazioni;
  • scorciatoie da tastiera;
  • pacchetti installati;
  • temi;
  • ricerca di nuovi pacchetti.

Localizzazione

È possibile impostare una lingua differente tramite l'installazione del pacchetto atom-i18n, omnicomprensivo di molte lingue. Per la lista delle lingue disponibili consultare questa questa pagina.

  1. Selezionare il menù Edit → Preferences.

  2. Selezionare la scheda Settings → +Install.

  3. Nel menù a tendina Language digitare atom-i18n.

  4. Premere su Install per scaricare ed eseguire l'installazione.

  5. Premere su Settings e scorrere verso il basso alla sezione Language.

  6. Selezionare nella casella di ricerca la lingua desiderata e accettare il riavvio dell'editor per caricare la lingua.

Terminale integrato

Sono disponibili all'installazione svariati terminali integrati, con caratteristiche diverse per adattarsi a specifiche necessità.

  1. Selezionare il menù Edit → Preferences... (Modifica → Preferenze) .

  2. Selezionare la scheda Settings → +Install (Impostazioni → +Installa).

  3. Nella barra ricerca digitare terminal.

  4. Scorrere la lista e fare clic sul tasto Install (Installa) di quello desiderato.

  5. Terminata l'installazione fare clic sul tasto Settings (Impostazioni) per personalizzare alle proprie necessità il funzionamento.

Scorciatoie da tastiera

Segue un elenco di alcune utili scorciatoie da tastiera:

Sequenza tasti

Funzionalità

Ctrl+

Accedere alle preferenze

Ctrl+O

Aprire file

Alt+shift+↓

Selezionare una colonna

Ctrl+D

Selezionare stringhe identiche a quella già selezionata

Ctrl+/

Commentare il codice

Ctrl+Alt+.

Completamento parentesi

Ctrl+j

Unire linee

Ctrl+m

Evidenziare parentesi/tag

Ctrl+Alt+m

Cursore fra parentesi/tag

Ctrl+l

Selezionare linea

Ctrl+Shift+d

Duplicare linea

Ctrl+↓

Muovere linea giù

Ctrl+↑

Muovere linea su

Ctrl+Enter

Inserire una nuova linea

Per aggiungere/modificare/eliminare le scorciatoie da tastiera seguire il menù Edit → Preferences → Keybindings (Modifica → Preferenze → Mappa Tasti).

Ulteriori risorse


CategoryProgrammazione CategoryProduttivita