Wiki Ubuntu-it

Indice
Partecipa
FAQ
Wiki Blog
------------------
Ubuntu-it.org
Forum
Chiedi
Chat
Cerca
Planet
  • Immutable Page
  • Info
  • Attachments

Redirected from page "Ufficio/OpenOffice.org"

Clear message


Guida verificata con Ubuntu: 20.04 22.04

Problemi in questa pagina? Segnalali in questa discussione

Introduzione

Apache OpenOffice è una suite per ufficio multipiattaforma e multilingua, distribuita con Licenza Apache. Con il nome OpenOffice.Org è stata la suite d'ufficio predefinita di Ubuntu fino alla versione 10.10, sostituita in seguito con LibreOffice. Per informazioni sulle differenze fra le due suite consultare questa pagina.

Nella seguente guida viene mostrato come installare la versione scaricabile dal sito ufficiale.

Installazione

L'installazione di OpenOffice non è compatibile con la versione di LibreOffice preinstallata e disponibile nei repository ufficiali.

È possibile installare nello stesso sistema LibreOffice accanto a OpenOffice seguendo le indicazioni di questo paragrafo.

Operazioni preliminari

Nel caso sia preinstallata la versione nei repository ufficiali di LibreOffice, occorre preventivamente rimuoverla.

  1. Eliminare il link simbolico /usr/bin/soffice digitando nel terminale:

    sudo rm /usr/bin/soffice
  2. Disinstallare completamente LibreOffice digitando nel terminale:

    sudo apt-get purge libreoffice*

Installazione dei pacchetti

Per installare OpenOffice:

  1. Scaricare il file .tar.gz da questo indirizzo, selezionando se necessario dal menu a tendina la versione desiderata. In via predefinita la pagina di download preseleziona le seguenti opzioni:

    • l'opzione Linux 32-bit (x86) (DEB) oppure Linux 64-bit (x86-64) (DEB), a seconda della propria architettura.

    • l'opzione Italian .

    • il tasto Download full installation per avere già inclusa la lingua italiana.

  2. Estrarre via terminale il contenuto dell'archivio .tar.gz nella propria Home.

  3. Spostare il file ~/OpenOffice/it-<versione>/DEBS/desktop-integration/openoffice<versione>-debian-menus nella cartella ~/OpenOffice/it-<versione>/DEBS (sostituire la voce «<versione> con quella effettiva).

  4. Spostarsi nella cartella ~/OpenOffice/it-<versione>/DEBS.

  5. Installare i pacchetti. È possibile eseguire questa operazione con un unico comando:

    sudo dpkg -i *.deb

Al termine della procedura, sarà possibile avviare le singole applicazioni di OpenOffice.

Ripristino LibreOffice (facoltativo)

Per permettere la compresenza di OpenOffice con LibreOffice è necessario installare quest'ultimo attraverso una modalità diversa dai pacchetti presenti nei repository ufficiali di Ubuntu. Scegliere quindi una fra le seguenti alternative:

Configurazione e funzionalità

Si consiglia di verificare sempre che le istruzioni siano compatibili con le versioni in uso di Ubuntu e di OpenOffice.

Lingua italiana

I pacchetti di installazione comprendono già tutto l'occorrente per la localizzazione del software.

  • Per modificare le impostazioni relative alla lingua utilizzare il menù Strumenti → Opzioni → Impostazioni della lingua.

  • Per effettuare un controllo ortografico di un testo:
    1. Selezionare il testo.
    2. Dal menù Formato → Carattere selezionare dal menù a tendina Lingua l'impostazione desiderata.

Aggiungere una collezione di clipart

  1. Installare il pacchetto openclipart.

  2. Seguire il menù Strumenti → Gallery, selezionare l'immagine desiderata e col tasto destro del mouse scegliere tra le varie opzioni che appariranno nel menù a discesa.

Se non è installato LibreOffice, potrebbero essere aggiunte dipendenze del programma.

Velocizzare l'avvio del programma

Per velocizzare l'avvio di OpenOffice seguire questa indicazione valida per Disabilitare Java:

Modificare la memoria in uso

  1. Avviare OpenOffice e seguire il menù Strumenti → Opzioni... → OpenOffice → Memoria principale.

  2. Nella voce Cache grafica impostare la quantità di memoria desiderata.

  3. Premere sul tasto Ok.

Nel caso si desideri usare intensamente le applicazioni Math e Draw, si consiglia d'impostare i seguenti valori minimi:

  • Uso di OpenOffice: 200 MB

  • Memoria per oggetto: 75 MB

  • Elimina dalla memoria dopo: 00.20 hh:mm

Guide specifiche

Ulteriori risorse


CategoryProduttivita