Wiki Ubuntu-it

Indice
Partecipa
FAQ
Wiki Blog
------------------
Ubuntu-it.org
Forum
Chiedi
Chat
Cerca
Planet
  • Immutable Page
  • Info
  • Attachments


Guida verificata con Ubuntu: 16.04 18.04

Problemi in questa pagina? Segnalali in questa discussione

Introduzione

Apache OpenOffice è una suite per ufficio multipiattaforma e multilingua.
Con il nome OpenOffice.Org è stata la suite d'ufficio predefinita di Ubuntu fino alla versione 10.10, sostituita in seguito con LibreOffice. Per informazioni sulle differenze fra le due suite consultare questa pagina.

Nella seguente guida viene mostrato come installare la versione scaricabile dal sito ufficiale.

Installazione

Poiché l'installazione di OpenOffice potrebbe comportare delle incompatibilità con LibreOffice, è opportuno adottare gli accorgimenti descritti di seguito.

Per ottimizzare la convivenza con OpenOffice, è possibile disinstallare la versione di LibreOffice presente nei repository e usufruire di quest'ultimo attraverso una modalità di installazione alternativa (tramite pacchetti snap, flatpak o la versione dev in formato AppImage).

Operazioni preliminari

Soltanto nel caso in cui si voglia utilizzare OpenOffice senza LibreOffice, seguire le istruzioni descritte di seguito. In caso contrario saltare questi passaggi e leggere il paragrafo successivo.

  1. Eliminare il link simbolico /usr/bin/soffice digitando nel terminale:

    sudo rm /usr/bin/soffice
  2. Disinstallare completamente LibreOffice digitando nel terminale:

    sudo apt-get purge libreoffice*

Installazione dei pacchetti

Per installare OpenOffice:

  1. Scaricare il file .tar.gz da questo indirizzo selezionando:

    • l'opzione Linux 32-bit (x86) (DEB) oppure Linux 64-bit (x86-64) (DEB) a seconda della propria architettura nel menu a tendina.

    • l'opzione Italian nel menu a tendina.

    • il tasto Download full installation per avere già inclusa la lingua italiana.

  2. Estrarre il contenuto dell'archivio .tar.gz nella propria Home.

  3. Spostarsi nella cartella DEBS con il terminale o tramite file manager e installare i pacchetti.
    È possibile eseguire questa operazione con un unico comando digitando nel terminale:

    sudo dpkg -i *.deb

    Non installare il file .deb contenuto nella cartella desktop-integration, che potrà anzi essere eliminata in caso di installazione accanto a LibreOffice.

OpenOffice sarà quindi installato.
Per permettere il corretto avvio del programma da menu, seguire le istruzioni del seguente paragrafo.

Creazione delle icone di avvio

A seconda della soluzione adottata, seguire una delle due opzioni riportate di seguito.

  • OpenOffice come unico programma: Spostarsi con il terminale nella cartella desktop-integration, quindi forzare l'installazione del pacchetto .deb contenuto all'interno, digitando:

    sudo dpkg -i --force-all *.deb
  • OpenOffice accanto a LibreOffice: Dal momento che il pacchetto openoffice-debian-menus non sarà installato, occorre creare le icone d'avvio nel menu. A tal fine, seguire le istruzioni di questa guida per creare degli avviatori che puntino ai seguenti file:

    • Pagina iniziale: opt/openoffice4/program/soffice

    • Writer: /opt/openoffice4/program/swriter

    • Calc: /opt/openoffice4/program/scalc

    • Draw: /opt/openoffice4/program/sdraw

    • Base: /opt/openoffice4/program/sbase

    • Impress: /opt/openoffice4/program/simpress

    • Math: /opt/openoffice4/program/smath

    • Gestione stampanti: /opt/openoffice4/share/xdg/printeradmin.desktop

    Qualora non si riuscissero a reperire delle icone per OpenOffice, è possibile estrarle dal file desktop-integration.deb.

Configurazione e funzionalità

Si consiglia di verificare sempre se le istruzioni sono compatibili con le versioni in uso di Ubuntu e di OpenOffice.

Lingua italiana

I pacchetti di installazione comprendono già tutto l'occorrente per la localizzazione del software.

  • Per modificare le impostazioni relative alla lingua utilizzare il menu Strumenti → Opzioni → Impostazioni della lingua.

  • Per effettuare un controllo ortografico di un testo:
    1. Selezionare il testo.
    2. Dal menu Formato → Carattere selezionare dal menu a tendina Lingua l'impostazione desiderata.

Aggiungere una collezione di clipart

  1. Installare il pacchetto openclipart.

  2. Seguire il menu Strumenti → Gallery, selezionare l'immagine desiderata e col tasto destro del mouse scegliere tra le varie opzioni che appariranno nel menu a discesa.

Se non è installato LibreOffice, potrebbero essere aggiunte dipendenze del programma.

Velocizzare l'avvio del programma

Per velocizzare l'avvio di OpenOffice seguire le stesse indicazioni valide per LibreOffice:

Guide specifiche

Ulteriori risorse


CategoryProduttivita