Wiki Ubuntu-it

Indice
Partecipa
FAQ
Wiki Blog
------------------
Ubuntu-it.org
Forum
Chiedi
Chat
Cerca
Planet
  • Immutable Page
  • Info
  • Attachments
  • Diff for "Programmazione/Poedit"
Differences between revisions 23 and 24
Revision 23 as of 20/10/2016 14.11.02
Size: 13360
Editor: wilecoyote
Comment:
Revision 24 as of 26/10/2016 14.54.43
Size: 13392
Comment:
Deletions are marked like this. Additions are marked like this.
Line 1: Line 1:
<<BR>>
Line 2: Line 3:
Line 185: Line 185:

----
CategoryHomepage


Guida verificata con Ubuntu: 16.04

Problemi in questa pagina? Segnalali in questa discussione

Introduzione

Poedit è un editor specializzato per tradurre i file con estensione .po. Questi file sono utilizzati per la traduzione di programmi e applicazioni per i quali sia disponibile il supporto Gettext.

Per agevolare il lavoro si consiglia di mantenere ordinata la propria Home creando una cartella specifica per le traduzioni.

Installazione

Per ottenere il programma installare il pacchetto poedit.

Reperire i file .po

I pacchetti da tradurre possono essere reperiti sia come già installati nel sistema e compilati in linguaggio machina in formato .mo, sia dai pacchetti sorgente in formato .pot o .po.

A tale scopo può risultare utile il Gestore Pacchetti Synaptic. Di seguito sono descritti le procedure per trovare attraverso questo strumento i file .mo già installati nel sistema, oppure per reperire il nome del sorgente in cui cercare il file .pot o .po.

Preinstallati

I file relativi alla versioni dei programmi nelle diverse lingue sono distribuiti in formato .mo. Per individuarli e convertirli in formato .pot (procedimento preliminare per la loro traduzione) seguire i seguenti passaggi:

  1. Avviare il programma Synaptic e cercare il pacchetto desiderato.

  1. Facendo clic destro sul nome del pacchetto, selezionare Proprietà dal menu contestuale e selezionare la scheda File installati. Quindi individuare e appuntare il percorso ai file .mo desiderati.

  2. Seguendo il percorso individuato, copiare tramite riga di comando il file nella propria Home (potrebbero essere necessari i privilegi di amministrazione.

  1. Spostarsi tramite riga di comando nella cartella dove è stato copiato il file.

  2. Convertire i file in .po digitare nel terminale il seguente comando:

    msgunfmt -o nome.po < nome.mo

    avendo cura di sostituire nome con il nome effettivo del file da convertire.

  1. Volendo o necessitando di eliminare eventuali traduzioni presenti digitare nel terminale il seguente comando:

    msgattrib --translated nome.po -o nome.pot

    avendo cura di sostituire nome con il nome effettivo del file da convertire.

Da sorgente

Qualora i pacchetti non fossero presenti nel sistema è possibile scaricare dai repository i sorgenti da cui estrarre gli eventuali file da tradurre, verificando anche la presenza della traduzione in lingua straniera di pacchetti compilati e distribuiti.

Seguire i seguenti passaggi:

  1. Avviare il programma Synaptic e cercare il pacchetto desiderato.

  2. Facendo clic destro sul nome del pacchetto, selezionare Proprietà dal menu contestuale e selezionare la scheda Comune. Quindi individuare e appuntare il nome del sorgente e la versione.

  3. Cercare e scaricare i sorgenti da questa pagina, avendo cura di

    • selezionare componente corretto (all'interno i file sono divisi in directory in ordine alfabetico)

    • selezionare la versione corretta
    • scaricare il file con estenzione .tar.xz.

  1. Estrarre il contenuto dei file scaricati nella propria Home, individuando i file .pot o in mancanza .po.

Le traduzioni dei pacchetti ufficialmente supportati vengono distribuite con i pacchetti language-pack-it, language-pack-gnome-it e language-pack-kde-it.

I nomi dei sorgenti delle librerie che iniziano con «lib» vanno cercati nelle corrispondenti voci «lib» del repository.

In mancanza di file .pot, seguire le istruzioni riportate sopra per detradurre i file .po da altre lingue.

Configurazione

Base

Cliccare su Modifica → Preferenze e seguire le istruzioni mostrate.

Nella sezione Modifica mettere la spunta a Compila automaticamente il file MO al salvataggio e Controllo ortografico semplificano il controllo e la creazione della traduzione in linguaggio macchina.

Creare Memoria di Traduzione in Trusty 14.04 LTS e versioni precedenti

Per creare la Memoria di traduzione (TM) bisogna cliccare su Aggiungi e selezionare it per l'italiano, selezionare il it apparso nella finestra e cliccare su Genera database, cliccare sull'icona nuovo elemento , seconda da sinistra in alto, digitare il percorso /usr/share/locale-langpack/it/LC_MESSAGES, ricliccare nuovo elemento e digitare /usr/share/locale/it/LC_MESSAGES, indi cliccare prima su Successivo e poi su Fine.

La creazione della memoria di traduzione può richiedere diverso tempo in dipendenza della quantità di file tradotti trovati.

Volendo tradurre in altre lingue si deve sostituire il it con la sigla della lingua scelta.

È anche possibile creare più Memorie di traduzione aggiungendo ulteriori lingue aggiungendo la relativa sigla.

Nella sezione Memoria di traduzione (TM) mettere la spunta a Traduci automaticamente all'aggiornamento del catalogo aggiornerà il database delle traduzioni.

Traduzione

File `.pot`

  1. Avviare il file manager e spostarsi nella cartella col file da tradurre.

  2. Fare clic sul file nome.pot creato.

  1. Fare clic su Creare una nuova traduzione e selezionare la lingua desiderata (ad esempio italiano (Italia)). Infine compilare in Catalogo → Proprietà i campi Traduttori: e Indirizzo email dei traduttori:, quindi salvare con nome.

  2. Cliccare su Catalogo → Proprietà.

  3. Scegliere in entrambi i campi relativi ai caratteri la codifica UTF-8 (consigliato)

    Se il file di traduzione verrà distribuito è raccomandabile compilare i campi Traduttori: ed Indirizzo email dei traduttori: con i dati reali in modo che chi ne usufruisce possa segnalare eventuali problemi.

  4. Procedere con la traduzione.

  5. Finita od interrotta la traduzione fare clic su File → Salva come... e salvare con lo stesso nome ed estensione .po, così di creare anche il file .mo.

File `.po`

  1. Avviare il file manager e spostarsi nella cartella col file da tradurre.

  2. Fare clic sul file .po.

  1. Riprendere la traduzione dove interrotta o incompleta.

  2. Finita od interrotta la traduzione fare clic su Salva, così facendo viene anche aggiornato il corrispondente file .mo.

Esecuzione

  1. Fare clic su Catalogo → Traduci automaticamente usando TM.

  2. Stringhe di colore blu.
    1. Nella lista in alto fare clic sulla stringa blu che si vuole tradurre.
    2. Nella finestra in basso digitare la traduzione.
    3. Ripetere per ciascuna stringa.
  3. Stringhe di colore arancio.
    1. Nella lista in alto fare clic su la stringa arancio che si vuole tradurre.
    2. Per accettare la traduzione suggerita fare clic su Non pronta.

    3. Per eventuali ulteriori possibili traduzioni fare clic col tasto destro sulla stessa stringa.
    4. Per accettare la traduzione alternativa suggerita fare clic sulla medesima.
    5. Nella finestra in basso per cancellare la traduzione preesistente selezionarla e fare clic con Ctrl+K.

    6. Digitare la propria traduzione.
    7. Ripetere per ciascuna stringa.
  4. Stringhe di colore nero.
    1. Nella finestra in basso per cancellare la traduzione preesistente selezionarla e fare clic su Ctrl+K.

    2. Digitare la propria traduzione.
    3. Ripetere per ciascuna stringa.

Allocazione delle traduzioni

Le traduzioni dei pacchetti supportati ufficialmente vanno allocate in /usr/share/locale-langpack/it/LC_MESSAGES, quelle degli altri pacchetti vanno allocate in /usr/share/locale/it/LC_MESSAGES

Onde evitare che un aggiornamento cancelli le traduzioni usare la directory /usr/local per allocare i file tradotti, inoltre creare un collegamento simbolico alla directory richiesta, spostando l'eventuale file .mo preesistente come backup.

Digitare nel terminale i seguenti comandi:

  1. Per spostare l'eventuale file .mo preesistente:

sudo mv /usr/share/locale-langpack/it/LC_MESSAGES/nome.mo /usr/share/locale-langpack/it/LC_MESSAGES/nome.mo~
 
 o
 
sudo mv /usr/share/locale/it/LC_MESSAGES/nome.mo /usr/share/locale/it/LC_MESSAGES/nome.mo~
  1. Per creare la directory dove allocare:

sudo mkdir -p /usr/local/share/locale-langpack/it/LC_MESSAGES

o

sudo mkdir -p /usr/local/share/locale/it/LC_MESSAGES
  1. Per allocare il file .mo:

sudo cp nome.mo /usr/local/share/locale-langpack/it/LC_MESSAGES/

o

sudo cp nome.mo /usr/local/share/locale/it/LC_MESSAGES/
  1. Per creare il collegamento simbolico:

sudo ln -s /usr/local/share/locale-langpack/it/LC_MESSAGES/nome.mo /usr/share/locale-langpack/it/LC_MESSAGES 

o

sudo ln -s /usr/local/share/locale/it/LC_MESSAGES/nome.mo /usr/share/locale/it/LC_MESSAGES

Ulteriori risorse


CategoryHomepage