Wiki Ubuntu-it

Indice
Partecipa
FAQ
Wiki Blog
------------------
Ubuntu-it.org
Forum
Chiedi
Chat
Cerca
Planet
  • Immutable Page
  • Info
  • Attachments
  • Diff for "Programmazione/Poedit"
Differences between revisions 46 and 47
Revision 46 as of 01/02/2018 14.38.15
Size: 13480
Editor: wilecoyote
Comment:
Revision 47 as of 24/04/2018 16.32.40
Size: 14733
Editor: wilecoyote
Comment:
Deletions are marked like this. Additions are marked like this.
Line 4: Line 4:
<<Informazioni(forum=''http://forum.ubuntu-it.org/viewtopic.php?f=46&t=614370''; rilasci="17.10 16.04 14.04")>> <<Informazioni(forum=''http://forum.ubuntu-it.org/viewtopic.php?f=46&t=614370''; rilasci="18.04 17.10 16.04 14.04")>>
Line 82: Line 82:
== Creare Memoria di Traduzione (Ubuntu 14.04 LTS e precedenti) == == Creare Memoria di Traduzione ==
Line 84: Line 84:
Per creare la '''Memoria di traduzione (TM)''' seguire come descritto di seguito. === Ubuntu 16.04 LTS e successivi ===

Per creare la '''Memoria di traduzione (TM)''' procedere come descritto di seguito.

 0. Scaricare i [[https://it.wikipedia.org/wiki/Codice_sorgente|pacchetti sorgente]] in formato compresso contenenti le traduzioni già pronte all'ultima versione dai [[Repository | repository ufficiali]], dalla sezione [[http://it.archive.ubuntu.com/ubuntu/pool/main/l/| main]] i pacchetti `language-pack-<sigla>-base` e `language-pack-gnome-<sigla>-base`, dalla sezione [[http://it.archive.ubuntu.com/ubuntu/pool/universe/k/| universe]] il pacchetto `kde-l10n-<sigla>`.
 0. Creare nella propria '''Home''' una cartella di nome '''PO-<sigla>''' (PO-it per l'italiano').
 0. [[AmministrazioneSistema/FormatiDiCompressione#decomprimere|Estrarre]] in essa i file `.po` contenuti nei file scaricati.
 0. Cliccare su '''Modifica → Preferenze''', selezionare la scheda '''MT''' e cliccare su '''Impara dai file...'''.
 0. Navigare e selezionare la cartella '''PO-<sigla>''' (PO-it per l'italiano').
 0. Selezionare tutti i file `nomefile.po` e cliccare su '''Apri'''.
Line 86: Line 95:
 0. Cliccare su '''Aggiungi''' e selezionare `sigla` nella finestra (`it` per la l'italiano).
=== Ubuntu 14.04 LTS e precedenti ===

Per creare la '''Memoria di traduzione (TM)''' procedere come descritto di seguito.
 
 0. Cliccare su '''Modifica → Preferenze''', selezionare la scheda '''Memoria di traduzione (MT)''', cliccare su '''Aggiungi''' e selezionare `sigla` nella finestra (`it` per l'italiano).
Line 91: Line 105:
 0. Ripetere eventualmente la procedura con una sigla della lingua differente, nel caso si vogliano tradurre  0. Ripetere eventualmente la procedura con una sigla d'un altro linguaggio differente, nel caso si voglia tradurre in ulteriori linguaggi.
 
Line 96: Line 111:


Guida verificata con Ubuntu: 16.04 18.04

Problemi in questa pagina? Segnalali in questa discussione

Introduzione

Poedit è un editor specializzato per tradurre i file con estensione .po. Questi file sono utilizzati per la traduzione di programmi e applicazioni per i quali sia disponibile il supporto Gettext.

Per semplificare la guida, sono di seguito utilizzati nomi generici. Pertanto sostituire sempre «nomefile» con il nome del pacchetto da tradurre e «sigla» con la sigla della lingua prescelta (ad esempio audacious.mo e it).

Installazione

Per ottenere il programma installare il pacchetto poedit.
Al termine dell'installazione sarà possibile avviare il programma.

Se assente, abilitare il Gestore Pacchetti Synaptic, che verrà utilizzato per reperire i file relativi alle traduzioni nei successivi passaggi.

Per agevolare il lavoro si consiglia di mantenere ordinata la propria Home creando un'apposita cartella dedicata alle traduzioni.

Reperire i file .po

Le traduzioni dei programmi nelle diverse lingue sono contenute all'interno di appositi file che possono essere liberamente tradotti. I file da tradurre possono essere reperiti

  • nel sistema stesso se il software da tradurre è già installato, in formato .mo convertibile in .po.

  • scaricando i pacchetti sorgente, in formato .pot o .po.

Seguire le istruzioni successive a seconda se il software è già installato o assente nel sistema.

Programmi installati

I file delle traduzioni dei pacchetti installati nel sistema sono in formato .mo e devono pertanto essere convertiti in .po. A tal fine seguire questi passaggi:

  1. Avviare il programma Synaptic e cercare il pacchetto desiderato.

  2. Fare clic con il tasto destro del mouse sul nome del pacchetto per aprire il menu contestuale e cliccare su Proprietà, quindi cliccare sulla scheda File installati.

  3. Individuare e prendere nota del percorso ai file con estensione .mo. Qualora non siano presenti file con questa estensione, chiudere il Gestore Pacchetti seguire le istruzioni di questo paragrafo.

  4. Seguendo il percorso individuato, copiare il file nella propria Home.

  5. Spostarsi tramite riga di comando nella cartella dove è stato copiato il file.

  6. Convertire i file in .po digitando nel terminale il seguente comando:

    msgunfmt -o nomefile.po < nomefile.mo
  7. Qualora si vuole rendere le stringhe già tradotte fuzzy, per poter scegliere se correggere o mantenere le traduzioni precedenti prima di salvare, digitare nel terminale il il comando:

    msgattrib --set-fuzzy nomefile.po -o nomefile.po

Da sorgente

Qualora i pacchetti non fossero presenti nel sistema, è possibile scaricare i sorgenti da cui estrarre i file da tradurre.

Nel caso di pacchetti non forniti da Ubuntu, scaricare i sorgenti direttamente dal manutentore o dallo sviluppatore e procedere con la loro traduzione.
Nel caso di pacchetti disponibili nei repository ufficiali di Ubuntu procedere con i seguenti passaggi:

  1. Avviare il programma Synaptic e cercare il pacchetto desiderato.

  2. Facendo clic destro sul nome del pacchetto, selezionare Proprietà dal menu contestuale e selezionare la scheda Comune. Quindi individuare e prendere nota del nome del sorgente e della versione.

  3. Cercare e scaricare i sorgenti da questa pagina, avendo cura di

    • selezionare il componente corretto (all'interno i file sono divisi in directory e disposti in ordine alfabetico).

    • selezionare la versione corretta.
    • scaricare il file con estenzione .tar.bz2, .tar.gz o.tar.xz.

  4. Estrarre il contenuto dei file scaricati nella propria Home. I file .pot richiesti sono solitamente contenuti nelle directory po o src/po. Se è disponibile, usare un file it.po per completare o modificare la traduzione.

  5. Qualora la directory non contienga nessun file .pot o .po e sia presente il file POTFILES.in, per creare il file .pot installare il pacchetto Intltool e digitare nel terminale il seguente comando:

    intltool-update --pot

Le traduzioni dei pacchetti ufficialmente supportati vengono distribuite con i pacchetti language-pack-it, language-pack-gnome-it e kde-l10n-it.

I nomi dei sorgenti delle librerie che iniziano con «lib» vanno cercati nelle corrispondenti voci «lib» del repository.

Primo avvio

Configurazione Base

È possibile accedere alle impostazioni del programma seguendo il menu Modifica → Preferenze.
Per semplificare l'utilizzo del programma può risultare utile spuntare all'interno della tab Generale le voci:

  • Compila automaticamente il file MO al salvataggio per creare automaticamente il file .mo.

  • Controllo ortografico per semplificare il controllo e la creazione della traduzione.

Inoltre nel menu Visualizza può risultare utile spuntare le voci a seconda delle proprie esigenze:

  • Visualizza ID elemento per visualizzare il numero identificativo delle stringhe.

  • Prima le voci con errori e/o Prima voci non tradotte per visualizzare raggruppate per prime le stringhe per le quali è necessarie correzioni o traduzioni.

Creare Memoria di Traduzione

Ubuntu 16.04 LTS e successivi

Per creare la Memoria di traduzione (TM) procedere come descritto di seguito.

  1. Scaricare i pacchetti sorgente in formato compresso contenenti le traduzioni già pronte all'ultima versione dai repository ufficiali, dalla sezione main i pacchetti language-pack-<sigla>-base e language-pack-gnome-<sigla>-base, dalla sezione universe il pacchetto kde-l10n-<sigla>.

  2. Creare nella propria Home una cartella di nome PO-<sigla> (PO-it per l'italiano').

  3. Estrarre in essa i file .po contenuti nei file scaricati.

  4. Cliccare su Modifica → Preferenze, selezionare la scheda MT e cliccare su Impara dai file....

  5. Navigare e selezionare la cartella PO-<sigla> (PO-it per l'italiano').

  6. Selezionare tutti i file nomefile.po e cliccare su Apri.

Ubuntu 14.04 LTS e precedenti

Per creare la Memoria di traduzione (TM) procedere come descritto di seguito.

  1. Cliccare su Modifica → Preferenze, selezionare la scheda Memoria di traduzione (MT), cliccare su Aggiungi e selezionare sigla nella finestra (it per l'italiano).

  2. Cliccare su Genera database e quindi sulla seconda icona a sinistra Nuovo elemento.

  3. Digitare il percorso /usr/share/locale-langpack/sigla/LC_MESSAGES (/usr/share/locale-langpack/it/LC_MESSAGES per l'italiano).

  4. Cliccare nuovamente su Nuovo elemento e digitare il percorso digitare /usr/share/locale/sigla/LC_MESSAGES (/usr/share/locale/it/LC_MESSAGES per l'italiano).

  5. Cliccare su Successivo e poi su Fine.

  6. Ripetere eventualmente la procedura con una sigla d'un altro linguaggio differente, nel caso si voglia tradurre in ulteriori linguaggi.

Se sono presenti molti file da tradurre la procedura può richiedere molto tempo.

Ponendo la spunta su Traduci automaticamente all'aggiornamento del catalogo nella sezione Memoria di traduzione (TM), si aggiornerà il database delle traduzioni.

Traduzione

Per tradurre i file è sufficiente cliccare sui file stessi, dopo aver aperto un file manager nella cartella in cui sono presenti. Verrà avviato così Poedit.

Seguire quindi la procedura come indicato di seguito, in base all'estensione del file (.pot o .po).

File .pot

  1. Fare clic su Creare una nuova traduzione e selezionare la lingua desiderata, ad esempio italiano (Italia).

  2. Seguire il menu Catalogo → Proprietà e compilare i campi Traduttori e Indirizzo email dei traduttori. Quindi salvare con nome.

  3. Seguire il menu Catalogo → Proprietà.

  4. Scegliere nei campi relativi ai caratteri la codifica UTF-8 (consigliato).

    Se il file di traduzione verrà distribuito si raccomanda di compilare i campi Traduttori ed Indirizzo email dei traduttori con dati reali affinché gli utenti possano segnalare eventuali problemi.

  5. Procedere con la traduzione.

  6. Terminata la traduzione, fare clic su File → Salva come... e salvare con lo stesso nome ed estensione .po, in modo tale da creare anche il relativo file .mo.

File .po

  1. Procedere con la traduzione.

  2. Terminata la traduzione, fare clic su Salva, in modo tale da aggiornare anche il corrispondente file .mo.

Istruzioni

  1. Seguire il menu Catalogo → Riempi traduzioni mancanti aprendole dalla MT.

  2. A seconda del colore delle stringhe, procedere come indicato di seguito:
    • Colore blu:
      1. Nella lista in alto cliccare sulla stringa blu per selezionarla.
      2. Nella finestra in basso digitare la traduzione.
      3. Ripetere per ciascuna stringa.
    • Colore arancio:
      1. Nella lista in alto cliccare sulla stringa arancio per selezionarla.
      2. Per accettare la traduzione suggerita fare clic su Non pronta.

      3. Per visualizzare eventuali ulteriori traduzioni fare clic destro sulla stessa stringa.
      4. Per accettare la traduzione alternativa suggerita cliccare sulla stessa.
      5. Per cancellare la traduzione precedente, selezionarla cliccando nella sezione Traduzione in basso e premere i tasti Ctrl + K..

      6. Digitare la propria traduzione.
      7. Ripetere per ciascuna stringa.
    • Colore nero:
      1. Per cancellare la traduzione precedente, selezionarla cliccando nella sezione Traduzione in basso e premere i tasti Ctrl + K.

      2. Digitare la propria traduzione.
      3. Ripetere per ciascuna stringa.

Allocazione delle traduzioni

Una volta tradotti i file, vanno allocati nelle seguenti cartelle:

  • /usr/share/locale-langpack/sigla/LC_MESSAGES (in sistemi in lingua italiana /usr/share/locale-langpack/it/LC_MESSAGES) per i pacchetti supportati ufficialmente da Ubuntu.

  • /usr/share/locale/sigla/LC_MESSAGES (in sistemi in lingua italiana /usr/share/locale/it/LC_MESSAGES) per i pacchetti non supportati ufficialmente da Ubuntu.

I regolari aggiornamenti di sistema potrebbero sovrascrivere le traduzioni precedentemente ottenute.
Per evitare questo inconveniente è consigliato: utilizzare la directory /usr/local per allocare i file tradotti, creare un collegamento simbolico alla directory richiesta, creare un backup dell'eventuale file .mo preesistente. Per eseguire tali operazioni utilizzare i comandi di seguito indicati, digitandoli in un terminale:

  • Per creare un backup dell'eventuale file .mo preesistente:

    sudo mv /usr/share/locale-langpack/sigla/LC_MESSAGES/nome.mo /usr/share/locale-langpack/sigla/LC_MESSAGES/nome.mo~

    oppure

    sudo mv /usr/share/locale/sigla/LC_MESSAGES/nome.mo /usr/share/locale/sigla/LC_MESSAGES/nome.mo~
  • Per creare la directory dove allocare le traduzioni:

    sudo mkdir -p /usr/local/share/locale-langpack/sigla/LC_MESSAGES

    oppure

    sudo mkdir -p /usr/local/share/locale/sigla/LC_MESSAGES
  • Per allocare il file .mo:

    sudo cp nome.mo /usr/local/share/locale-langpack/sigla/LC_MESSAGES/

    oppure

    sudo cp nome.mo /usr/local/share/locale/sigla/LC_MESSAGES/
  • Per creare il collegamento simbolico:

    sudo ln -s /usr/local/share/locale-langpack/sigla/LC_MESSAGES/nome.mo /usr/share/locale-langpack/sigla/LC_MESSAGES 

    oppure

    sudo ln -s /usr/local/share/locale/sigla/LC_MESSAGES/nome.mo /usr/share/locale/sigla/LC_MESSAGES

Ulteriori risorse


CategoryProgrammazione