Wiki Ubuntu-it

Indice
Partecipa
FAQ
Wiki Blog
------------------
Ubuntu-it.org
Forum
Chiedi
Chat
Cerca
Planet
  • Immutable Page
  • Info
  • Attachments
  • Diff for "Programmazione/Poedit"
Differences between revisions 31 and 32
Revision 31 as of 15/11/2016 14.19.27
Size: 12605
Comment:
Revision 32 as of 15/11/2016 14.31.28
Size: 12604
Comment:
Deletions are marked like this. Additions are marked like this.
Line 74: Line 74:
 0. Cliccare su '''Aggiungi''' e selezionare `sigla` nella finestra (`it` per la l'italiano)).  0. Cliccare su '''Aggiungi''' e selezionare `sigla` nella finestra (`it` per la l'italiano).


Guida verificata con Ubuntu: 16.04

Problemi in questa pagina? Segnalali in questa discussione

Introduzione

Poedit è un editor specializzato per tradurre i file con estensione .po. Questi file sono utilizzati per la traduzione di programmi e applicazioni per i quali sia disponibile il supporto Gettext.

Per semplificare la guida, sono di seguito utilizzati nomi generici. Pertanto sostituire sempre «nomefile» con il nome del pacchetto da tradurre e «sigla» con la sigla della lingua prescelta (ad esempio audacious.mo e it).

Installazione

Per ottenere il programma installare il pacchetto poedit.

Se assente, abilitare il Gestore Pacchetti Synaptic, che verrà utilizzato per reperire i file relativi alle traduzioni nei successivi passaggi.

Per agevolare il lavoro si consiglia di mantenere ordinata la propria Home creando un'apposita cartella dedicata alle traduzioni.

Reperire i file .po

Le traduzioni dei programmi nelle diverse lingue sono contenute all'interno di appositi file che possono essere liberamente tradotti. I file da tradurre possono essere reperiti

  • nel sistema stesso se il software da tradurre è già installato, in formato .mo convertibile in .po.

  • scaricando i pacchetti sorgente, in formato .pot o .po.

Seguire le istruzioni successive a seconda se il software è già installato o assente nel sistema.

Programmi installati

I file delle traduzioni dei pacchetti installati nel sistema sono in formato .mo e devono pertanto essere convertiti in .po. A tal fine seguire questi passaggi:

  1. Avviare il programma Synaptic e cercare il pacchetto desiderato.

  2. Fare clic con il tasto destro del mouse sul nome del pacchetto per aprire il menu contestuale e cliccare su Proprietà, quindi cliccare sulla scheda File installati.

  3. Individuare e prendere nota del percorso ai file con estensione .mo. Qualora non siano presenti file con questa estensione, chiudere il Gestore Pacchetti seguire le istruzioni di questo paragrafo.

  4. Seguendo il percorso individuato, copiare il file nella propria Home.

  5. Spostarsi tramite riga di comando nella cartella dove è stato copiato il file.

  6. Convertire i file in .po digitando nel terminale il seguente comando:

    msgunfmt -o nomefile.po < nomefile.mo
  7. Qualora si vogliano anche eliminare traduzioni precedenti, digitare nel terminale il il comando:

    msgattrib --translated nomefile.po -o nomefile.pot

Da sorgente

Qualora i pacchetti non fossero presenti nel sistema, è possibile scaricare dai repository i sorgenti da cui estrarre gli eventuali file da tradurre, verificando anche la presenza della traduzione in lingua straniera di pacchetti compilati e distribuiti.

Seguire i seguenti passaggi:

  1. Avviare il programma Synaptic e cercare il pacchetto desiderato.

  2. Facendo clic destro sul nome del pacchetto, selezionare Proprietà dal menu contestuale e selezionare la scheda Comune. Quindi individuare e prendere nota del nome del sorgente e della versione.

  3. Cercare e scaricare i sorgenti da questa pagina, avendo cura di

    • selezionare il componente corretto (all'interno i file sono divisi in directory disposti in ordine alfabetico)

    • selezionare la versione corretta
    • scaricare il file con estenzione .tar.xz.

  4. Estrarre il contenuto dei file scaricati nella propria Home, individuando i file .pot. Qualora al posto di quest'ultimi siano presenti file in formato .po, è possibile convertirli seguendo le istruzioni del paragrafo precedente.

Le traduzioni dei pacchetti ufficialmente supportati vengono distribuite con i pacchetti language-pack-it, language-pack-gnome-it e language-pack-kde-it.

I nomi dei sorgenti delle librerie che iniziano con «lib» vanno cercati nelle corrispondenti voci «lib» del repository.

Primo avvio

Configurazione Base

  1. Selezionare il menu Modifica → Preferenze e seguire le indicazioni presenti a schermo.

  2. Nella sezione Modifica spuntare Compila automaticamente il file MO al salvataggio e Controllo ortografico per semplificare il controllo e la creazione della traduzione in linguaggio macchina.

Creare Memoria di Traduzione (Ubuntu 14.04 LTS e precedenti)

Per creare la Memoria di traduzione (TM) seguire come descritto di seguito.

  1. Cliccare su Aggiungi e selezionare sigla nella finestra (it per la l'italiano).

  2. Cliccare su Genera database e quindi sulla seconda icona a sinistra Nuovo elemento.

  3. Digitare il percorso /usr/share/locale-langpack/sigla/LC_MESSAGES (/usr/share/locale-langpack/it/LC_MESSAGES per l'italiano).

  4. Cliccare nuovamente su Nuovo elemento e digitare il percorso digitare /usr/share/locale/sigla/LC_MESSAGES (/usr/share/locale/it/LC_MESSAGES per l'italiano).

  5. Cliccare su Successivo e poi su Fine.

  6. Ripetere eventualmente la procedura con una sigla della lingua differente, nel caso si vogliano tradurre

Se sono presenti molti file da tradurre la procedura può richiedere molto tempo.

Ponendo la spunta su Traduci automaticamente all'aggiornamento del catalogo nella sezione Memoria di traduzione (TM), si aggiornerà il database delle traduzioni.

Traduzione

Prima di tradurre i file precedentemente ricavati, è necessario

File `.pot`

  1. Avviare il file manager e spostarsi nella cartella col file da tradurre.

  2. Fare clic sul file nome.pot creato.

  1. Fare clic su Creare una nuova traduzione e selezionare la lingua desiderata (ad esempio italiano (Italia)). Infine compilare in Catalogo → Proprietà i campi Traduttori: e Indirizzo email dei traduttori:, quindi salvare con nome.

  2. Cliccare su Catalogo → Proprietà.

  3. Scegliere in entrambi i campi relativi ai caratteri la codifica UTF-8 (consigliato)

    Se il file di traduzione verrà distribuito è raccomandabile compilare i campi Traduttori: ed Indirizzo email dei traduttori: con i dati reali in modo che chi ne usufruisce possa segnalare eventuali problemi.

  4. Procedere con la traduzione.

  5. Finita od interrotta la traduzione fare clic su File → Salva come... e salvare con lo stesso nome ed estensione .po, così di creare anche il file .mo.

File `.po`

  1. Avviare il file manager e spostarsi nella cartella col file da tradurre.

  2. Fare clic sul file .po.

  1. Riprendere la traduzione dove interrotta o incompleta.

  2. Finita od interrotta la traduzione fare clic su Salva, così facendo viene anche aggiornato il corrispondente file .mo.

Esecuzione

  1. Fare clic su Catalogo → Traduci automaticamente usando TM.

  2. Stringhe di colore blu.
    1. Nella lista in alto fare clic sulla stringa blu che si vuole tradurre.
    2. Nella finestra in basso digitare la traduzione.
    3. Ripetere per ciascuna stringa.
  3. Stringhe di colore arancio.
    1. Nella lista in alto fare clic su la stringa arancio che si vuole tradurre.
    2. Per accettare la traduzione suggerita fare clic su Non pronta.

    3. Per eventuali ulteriori possibili traduzioni fare clic col tasto destro sulla stessa stringa.
    4. Per accettare la traduzione alternativa suggerita fare clic sulla medesima.
    5. Nella finestra in basso per cancellare la traduzione preesistente selezionarla e fare clic con Ctrl+K.

    6. Digitare la propria traduzione.
    7. Ripetere per ciascuna stringa.
  4. Stringhe di colore nero.
    1. Nella finestra in basso per cancellare la traduzione preesistente selezionarla e fare clic su Ctrl+K.

    2. Digitare la propria traduzione.
    3. Ripetere per ciascuna stringa.

Allocazione delle traduzioni

Una volta tradotti i file, vanno allocati nelle seguenti cartelle:

  • /usr/share/locale-langpack/sigla/LC_MESSAGES (in sistemi in lingua italiana /usr/share/locale-langpack/it/LC_MESSAGES) per i pacchetti supportati ufficialmente da Ubuntu.

  • /usr/share/locale/sigla/LC_MESSAGES (in sistemi in lingua italiana /usr/share/locale/it/LC_MESSAGES) per i pacchetti non supportati ufficialmente da Ubuntu.

I regolari aggiornamenti di sistema potrebbero sovrascrivere le traduzioni precedentemente ottenute.
Per evitare questo inconveniente è consigliato: utilizzare la directory /usr/local per allocare i file tradotti, creare un collegamento simbolico alla directory richiesta, creare un backup dell'eventuale file .mo preesistente. Per eseguire tali operazioni utilizzare i comandi di seguito indicati, digitandoli in un terminale:

  • Per creare un backup dell'eventuale file .mo preesistente:

    sudo mv /usr/share/locale-langpack/sigla/LC_MESSAGES/nome.mo /usr/share/locale-langpack/sigla/LC_MESSAGES/nome.mo~

    oppure

    sudo mv /usr/share/locale/sigla/LC_MESSAGES/nome.mo /usr/share/locale/sigla/LC_MESSAGES/nome.mo~
  • Per creare la directory dove allocare le traduzioni:

    sudo mkdir -p /usr/local/share/locale-langpack/sigla/LC_MESSAGES

    oppure

    sudo mkdir -p /usr/local/share/locale/sigla/LC_MESSAGES
  • Per allocare il file .mo:

    sudo cp nome.mo /usr/local/share/locale-langpack/sigla/LC_MESSAGES/

    oppure

    sudo cp nome.mo /usr/local/share/locale/sigla/LC_MESSAGES/
  • Per creare il collegamento simbolico:

    sudo ln -s /usr/local/share/locale-langpack/sigla/LC_MESSAGES/nome.mo /usr/share/locale-langpack/sigla/LC_MESSAGES 

    oppure

    sudo ln -s /usr/local/share/locale/sigla/LC_MESSAGES/nome.mo /usr/share/locale/sigla/LC_MESSAGES

Ulteriori risorse


CategoryHomepage