Wiki Ubuntu-it

Indice
Partecipa
FAQ
Wiki Blog
------------------
Ubuntu-it.org
Forum
Chiedi
Chat
Cerca
Planet
  • Immutable Page
  • Info
  • Attachments
  • Diff for "Programmazione/Poedit"
Differences between revisions 19 and 20
Revision 19 as of 07/10/2016 14.48.09
Size: 11695
Editor: wilecoyote
Comment:
Revision 20 as of 07/10/2016 16.13.18
Size: 8952
Comment:
Deletions are marked like this. Additions are marked like this.
Line 9: Line 9:
 ------
 
Line 15: Line 13:
------
Line 19: Line 15:
I pacchetti da tradurre possono essere recuperati sia dal sistema sia dai pacchetti sorgente, per trovarli nel sistema viene utile il pacchetto [[apt://synaptic | synaptic]]. I pacchetti da tradurre possono essere recuperati sia dal sistema sia dai pacchetti sorgente.

P
er trovarli nel sistema è utile il [[AmministrazioneSistema/InstallareProgrammi/GestorePacchetti| Gestore Pacchetti Synaptic]].
Line 23: Line 21:
Cercare quelli già installati nel file system nella propria o altre lingue in formato `.mo`, da convertire in formato `.po` per poterli tradurre. Per reperire quelli già installati nel proprio sistema o altre lingue in formato `.mo`, in modo tale da convertirli in formato `.po` e quindi tradurli, seguire i seguenti passaggi:
Line 25: Line 23:
||<tablestyle="text-align: justify; width:100%;" style="border:none;" 5%><<Immagine(Icone/Grandi/info.png,,center)>> ||<style="padding:0.5em; border:none;">Per mantenere ordinata la propria "Home" si consiglia di creare una cartella specifica per le traduzioni. ||

 0. '''[[AmbienteGrafico/AvviareProgrammi|Avviare]]''' il programma '''[[AmministrazioneSistema/InstallareProgrammi/GestorePacchetti|Synaptic]]'''.
 0. Nella finestra del programma fare clic su ''Cerca'', nella piccola finestra apparsa digitare il nome del pacchetto in ''Cerca:'', selezionare ''descrizione e nome'' in ''Cerca in:'' e fare clic su ''Cerca''.
 0. Fare clic col tasto destro del mouse sul nome del pacchetto.
 0. Fare clic su ''File installati''.
 0. Scorrere l'elenco dei file installati e leggere il percorso del file `.mo`.
 0. '''[[AmbienteGrafico/AvviareProgrammi|Avviare]]''' il '''file manager'''.
 0. Seguire il percorso letto nell'albero del file system e copiare il file `.mo` nella cartella prescelta nella "Home".
 0. Per convertire i file `.mo` in file `.po` digitare nel [[AmministrazioneSistema/RigaDiComando|terminale]] i seguenti comandi:

{{{
cd /home/nomeutente/cartellaprescelta
 0. '''[[AmbienteGrafico/AvviareProgrammi|Avviare]]''' il programma '''Synaptic''', cercare il pacchetto richiesto per nome, fare clic sulla scheda '''File installati''', quindi individuare il percorso ai file `.qm`.
 0. Seguendo il percorso individuato copiare il file `.qm` nella cartella prescelta nella '''Home''', usando se necessario i [[AmministrazioneSistema/Sudo|privilegi di amministrazione]].
 0. [[AmministrazioneSistema/ComandiBase#cd|Spostarsi tramite riga di comando]] nella cartella dove è stato copiato il file.
 0. Per convertire i file `.mo` in file `.po` digitare nel [[AmministrazioneSistema/RigaDiComando|terminale]] il seguente comando: {{{
Line 40: Line 29:

 0. Per rimuovere le traduzioni già fatte in lingua straniera o azzerare quelle in italiano digitare nel [[AmministrazioneSistema/RigaDiComando|terminale]] il seguente comando:

{{{
 avendo cura di sostituire '''nome.po''' e '''nome.mo''' con i nomi effettivi dei file utilizzati.
 0. Per eliminare eventuali traduzioni digitare nel [[AmministrazioneSistema/RigaDiComando|terminale]] il seguente comando: {{{
Line 46: Line 33:
 avendo cura di sostituire '''nome.pot''' e '''nome.mo''' con i nomi effettivi dei file utilizzati.
 0. Aprire il file `.pot` creato con '''oedit'''.
 0. Fare clic su ''Creare una nuova traduzione'' e selezionare ''italiano (Italia)''. Infine compilare in ''Catalogo → Proprietà'' i campi '''Traduttori:''' e '''Indirizzo email dei traduttori:''', quindi salvare con nome.

||<tablestyle="text-align: justify; width:100%;" style="border:none;" 5%><<Immagine(Icone/Grandi/info.png,,center)>> ||<style="padding:0.5em; border:none;">Per mantenere ordinata la propria '''Home''' si consiglia di creare una cartella specifica per le traduzioni. ||
Line 49: Line 41:
Se la ricerca non dà risultato, è utile scaricare i sorgenti dai [[Repository|repository]] per verificare l'eventuale presenza dei file `.pot`, o file `.po` in tutto o in parte già tradotti spesso in lingua straniera, non inclusi nei pacchetti compilati e distribuiti. Se la ricerca non dà risultato, è utile scaricare i sorgenti dai [[wiki.ubuntu-it.org/Repository | repository]] per verificare l'eventuale presenza dei file `.pot`, o file `.po` tutto o in parte già tradotti spesso in lingua straniera, non inclusi nei pacchetti compilati e distribuiti.
Line 51: Line 43:
 0. '''[[AmbienteGrafico/AvviareProgrammi|Avviare]]''' il programma '''[[AmministrazioneSistema/InstallareProgrammi/GestorePacchetti|Synaptic]]'''.
 0. Nella finestra del programma fare clic su ''Cerca'', nella piccola finestra apparsa digitare il nome del pacchetto in ''Cerca:'', selezionare ''descrizione e nome'' in ''Cerca in:'' e fare clic su ''Cerca''.
 0. Fare clic col tasto destro del mouse sul nome del pacchetto.
 0. Fare clic sulla scheda ''Comune'' e leggere il nome del sorgente e la versione.
+ 0. '''[[AmbienteGrafico/AvviareProgrammi|Avviare]]''' il programma Navigatore.
+
 0. '''[[AmbienteGrafico/AvviareProgrammi|Avviare]]''' il programma '''[[AmministrazioneSistema/InstallareProgrammi/GestorePacchetti|Synaptic]]''', cercare il pacchetto richiesto per nome, fare clic sulla scheda ''Comune'' e leggere il nome del sorgente e la versione.
Line 58: Line 46:
 0. '''[[AmbienteGrafico/AvviareProgrammi|Avviare]]''' il '''file manager'''.
 0. Selezionare la cartella dove salvato ed '''[[AmministrazioneSistema/FormatiDiCompressione#decomprimere|estrarre]]''' il contenuto dei '''[[https://it.wikipedia.org/wiki/File_sorgente|sorgenti]]''' nella propria '''Home'''.
 0. Copiare il file `.pot`, in mancanza un file `.po`, nella cartella prescelta nella "Home" per la traduzione.

 0. '''[[AmministrazioneSistema/FormatiDiCompressione#decomprimere|Estrarre]]''' il contenuto dei '''[[https://it.wikipedia.org/wiki/File_sorgente|sorgenti]]''' nella propria '''Home''', copiare il file `.pot`, in mancanza il file `.po`, nella cartella specifica per la traduzione.
Line 68: Line 55:
------

= Configurazione di Poedit =
= Configurazione =
Line 74: Line 59:
Fare clic su '''''Modifica → Preferenze''''' e seguire le istruzioni mostrate. Cliccare su ''Modifica → Preferenze'' e seguire le istruzioni mostrate.
Line 78: Line 63:
=== Creare Memoria di Traduzione in Trusty 14.04 LTS e versioni precedenti === === Creare Memoria di Traduzione in Trusty 14.04 LTS e versioni precdenti ===
Line 90: Line 75:
= Traduzione = == Traduzione ==
Line 92: Line 77:
== Configurazione del file da tradurre ==  Cliccare su ''Catalogo → Proprietà''
Line 94: Line 79:
 0. '''[[AmbienteGrafico/AvviareProgrammi|Avviare]]''' il '''file manager'''.
 0. Fare clic sul file `.pot` creato con [[apt://poedit | poedit]].
 0. Fare clic su ''Catalogo → Proprietà''.
 0. Scegliere in entrambi i campi relativi ai caratteri la codifica ''UTF-8 (consigliato)''.
 0. Digitare, nel campo ''Forme plurali:'' → ''nplurals=2; plural=(n !=1);'', se si traduce in altre lingue fare clic su '''Informazioni su forme plurali''' e modificare in base al plurale della lingua prescelta.
 0. Fare clic su '''Ok'''.
 0. fare clic su '''''File → Salva come...''''' e salvare con `nome.po`.
Scegliere in entrambi i campi relativi ai caratteri la codifica ''UTF-8 (consigliato)''
Line 102: Line 81:
||<tablestyle="text-align: justify; width:100%;" style="border:none;" 5%><<Immagine(Icone/Piccole/note.png,,center)>> ||<style="padding:0.5em; border:none;"> ''Se il file di traduzione verrà distribuito è raccomandabile compilare i campi ''Traduttori:'' ed ''Indirizzo email dei traduttori:'' con i dati reali in modo che chi ne usufruisce possa segnalare eventuali problemi.''|| ||<tablestyle="text-align: justify; width:100%;" style="border:none;" 5%><<Immagine(Icone/Piccole/note.png,,center)>> ||<style="padding:0.5em; border:none;"> ''Se il file di traduzione verrà distribuito è raccomandabile compilare i campi '''Traduttori:''' ed '''Indirizzo email dei traduttori:''' con i dati reali in modo che chi ne usufruisce possa segnalare eventuali problemi.''||
Line 104: Line 83:
=== Esecuzione ===

 0. Fare clic su '''''Catalogo → Traduci automaticamente usando TM'''''.
 0. Stringhe di colore blu
   0. Nella lista in alto fare clic su la stringa blu che si vuole tradurre.
   0. Nella finestra in basso digitare la traduzione.
   0. Ripetere per ciascuna stringa.
 0. Stringhe di colore arancio
   0. Nella lista in alto fare clic su la stringa arancio che si vuole tradurre.
   0. Per accettare la traduzione suggerita fare clic su '''Non pronta'''.
   0. Per eventuali ulteriori possibili traduzioni fare clic col tasto destro sulla stessa stringa.
   0. Per accettare la traduzione alternativa suggerita fare clic sulla medesima.
   0. Nella finestra in basso per cancellare la traduzione preesistente selezionarla e fare clic con '''Ctrl+K'''.
   0. Digitare la propria traduzione.
   0. Ripetere per ciascuna stringa.
 0. Stringhe di colore nero
    0. Nella finestra in basso per cancellare la traduzione preesistente selezionarla e fare clic su '''Ctrl+K'''.
   0. Digitare la propria traduzione.
   0. Ripetere per ciascuna stringa.
 0. Completate le traduzioni fare clic su '''Salva'''.
 
||<tablestyle="text-align: justify; width:100%;" style="border:none;" 5%><<Immagine(Icone/Piccole/note.png,,center)>> ||<style="padding:0.5em; border:none;">''La ritraduzione delle stringhe di colore nero di regola non serve.''||

||<tablestyle="text-align: justify; width:100%;" style="border:none;" 5%><<Immagine(Icone/Grandi/info.png,,center)>> ||<style="padding:0.5em; border:none;">La traduzione si può interrompere e ricominciare successivamente, fare clic sul file `nome.po` per riavviare il l'editor, in tale frangente non serve rifare le configurazioni.||
 ------
Finite le traduzioni procedere a salvare, così di creare il file `.mo`.
Line 178: Line 133:
------
Line 182: Line 135:
[[https://poedit.net/ | Sito ufficiale Poedit]]
<<BR>>
[[https://www.gnu.org/software/gettext/| Sito ufficiale Gettext]]

 --------------------------------------------------------
 
  l'indicazione di usare Synaptic è dovuta alla facilità con cui rende possibile trovare i percorsi dei file indicati, altri gestori pacchetti sono meno efficaci oltre che spesso oggetto di svariate discussioni con richieste d'aiuto per problemi di funzionamento.
 * [[https://poedit.net/ | Sito ufficiale del progetto]]
 * [[https://www.gnu.org/software/gettext/| Sito ufficiale Gettext]]

Guida verificata con Ubuntu: 16.04

Problemi in questa pagina? Segnalali in questa discussione

Introduzione

Il programma Poedit è un editor specializzato per tradurre i file .po usati per internazionalizzare i programmi, utile per programmi od applicazioni non ancora tradotte in cui è disponibile il supporto Gettext.

Installazione

Installare il pacchetto poedit.

I file .po

I pacchetti da tradurre possono essere recuperati sia dal sistema sia dai pacchetti sorgente.

Per trovarli nel sistema è utile il Gestore Pacchetti Synaptic.

Preinstallati

Per reperire quelli già installati nel proprio sistema o altre lingue in formato .mo, in modo tale da convertirli in formato .po e quindi tradurli, seguire i seguenti passaggi:

  1. Avviare il programma Synaptic, cercare il pacchetto richiesto per nome, fare clic sulla scheda File installati, quindi individuare il percorso ai file .qm.

  2. Seguendo il percorso individuato copiare il file .qm nella cartella prescelta nella Home, usando se necessario i privilegi di amministrazione.

  3. Spostarsi tramite riga di comando nella cartella dove è stato copiato il file.

  4. Per convertire i file .mo in file .po digitare nel terminale il seguente comando:

    msgunfmt -o nome.po < nome.mo

    avendo cura di sostituire nome.po e nome.mo con i nomi effettivi dei file utilizzati.

  5. Per eliminare eventuali traduzioni digitare nel terminale il seguente comando:

    msgattrib --translated nome.po -o nome.pot

    avendo cura di sostituire nome.pot e nome.mo con i nomi effettivi dei file utilizzati.

  6. Aprire il file .pot creato con oedit.

  7. Fare clic su Creare una nuova traduzione e selezionare italiano (Italia). Infine compilare in Catalogo → Proprietà i campi Traduttori: e Indirizzo email dei traduttori:, quindi salvare con nome.

Per mantenere ordinata la propria Home si consiglia di creare una cartella specifica per le traduzioni.

Da sorgente

Se la ricerca non dà risultato, è utile scaricare i sorgenti dai repository per verificare l'eventuale presenza dei file .pot, o file .po tutto o in parte già tradotti spesso in lingua straniera, non inclusi nei pacchetti compilati e distribuiti.

  1. Avviare il programma Synaptic, cercare il pacchetto richiesto per nome, fare clic sulla scheda Comune e leggere il nome del sorgente e la versione.

  2. Cercare e scaricare i tarball dei sorgenti dal repository ufficiale, selezionare il repository appropriato, fare clic sulla lettera iniziale, scorrere la lista fino a trovare il nome del sorgente e cliccare sopra, infine scaricare la versione richiesta.

  3. Estrarre il contenuto dei sorgenti nella propria Home, copiare il file .pot, in mancanza il file .po, nella cartella specifica per la traduzione.

Le traduzioni dei pacchetti ufficialmente supportati vengono distribuite con i pacchetti language-pack-it, language-pack-gnome-it e language-pack-kde-it.

I nomi dei sorgenti delle librerie che iniziano con «lib» vanno cercati nelle corrispondenti voci «lib» del repository.

In mancanza di file .pot, seguire le istruzioni riportate sopra per detradurre i file .po da altre lingue.

Configurazione

Base

Cliccare su Modifica → Preferenze e seguire le istruzioni mostrate.

Nella sezione Modifica mettere la spunta a Compila automaticamente il file MO al salvataggio e Controllo ortografico semplificano il controllo e la creazione della traduzione in linguaggio macchina.

Creare Memoria di Traduzione in Trusty 14.04 LTS e versioni precdenti

Per creare la Memoria di traduzione (TM) bisogna cliccare su Aggiungi e selezionare it per l'italiano, selezionare il it apparso nella finestra e cliccare su Genera database, cliccare sull'icona nuovo elemento , seconda da sinistra in alto, digitare il percorso /usr/share/locale-langpack/it/LC_MESSAGES, ricliccare nuovo elemento e digitare /usr/share/locale/it/LC_MESSAGES, indi cliccare prima su Successivo e poi su Fine.

La creazione della memoria di traduzione può richiedere diverso tempo in dipendenza della quantità di file tradotti trovati.

Volendo tradurre in altre lingue si deve sostituire il it con la sigla della lingua scelta.

È anche possibile creare più Memorie di traduzione aggiungendo ulteriori lingue aggiungendo la relativa sigla.

Nella sezione Memoria di traduzione (TM) mettere la spunta a Traduci automaticamente all'aggiornamento del catalogo aggiornerà il database delle traduzioni.

Traduzione

  • Cliccare su Catalogo → Proprietà

Scegliere in entrambi i campi relativi ai caratteri la codifica UTF-8 (consigliato)

Se il file di traduzione verrà distribuito è raccomandabile compilare i campi Traduttori: ed Indirizzo email dei traduttori: con i dati reali in modo che chi ne usufruisce possa segnalare eventuali problemi.

Finite le traduzioni procedere a salvare, così di creare il file .mo.

Allocazione delle traduzioni

Le traduzioni dei pacchetti supportati ufficialmente vanno allocate in /usr/share/locale-langpack/it/LC_MESSAGES, quelle degli altri pacchetti vanno allocate in /usr/share/locale/it/LC_MESSAGES

Ad evitare che un aggiornamento cancelli le traduzioni è consigliabile usare la directory /usr/local per allocare i file tradotti, e creare un collegamento simbolico alla directory richiesta, spostando l'eventuale file .mo preesistente come backup.

Digitare nel terminale i seguenti comandi:

  1. Per spostare l'eventuale file .mo preesistente:

sudo mv /usr/share/locale-langpack/it/LC_MESSAGES/nome.mo /usr/share/locale-langpack/it/LC_MESSAGES/nome.mo~
 
 o
 
sudo mv /usr/share/locale/it/LC_MESSAGES/nome.mo /usr/share/locale/it/LC_MESSAGES/nome.mo~
  1. Per creare la directory dove allocare:

sudo mkdir -p /usr/local/share/locale-langpack/it/LC_MESSAGES

o

sudo mkdir -p /usr/local/share/locale/it/LC_MESSAGES
  1. Per allocare il file .mo:

sudo cp nome.mo /usr/local/share/locale-langpack/it/LC_MESSAGES/

o

sudo cp nome.mo /usr/local/share/locale/it/LC_MESSAGES/
  1. Per creare il collegamento simbolico:

sudo ln -s /usr/local/share/locale-langpack/it/LC_MESSAGES/nome.mo /usr/share/locale-langpack/it/LC_MESSAGES 

o

sudo ln -s /usr/local/share/locale/it/LC_MESSAGES/nome.mo /usr/share/locale/it/LC_MESSAGES

Ulteriori risorse