Wiki Ubuntu-it

Indice
Partecipa
FAQ
Wiki Blog
------------------
Ubuntu-it.org
Forum
Chiedi
Chat
Cerca
Planet
  • Immutable Page
  • Info
  • Attachments


Guida verificata con Ubuntu: 18.04 20.04

Problemi in questa pagina? Segnalali in questa discussione

Introduzione

Il programma PartitionManager serve per creare, modificare, cancellare e ridimensionare partizioni e filesystem, tramite interfaccia grafica.

Utile anche per eseguire il partizionamento manuale propedeutico all'installazione di Kubuntu sul disco rigido.

Operando sulle partizioni si corre il rischio in caso di errore di perdere i dati presenti sul disco rigido. È fortemente raccomandato di fare una copia di backup dei propri dati prima di proseguire.

Nozioni basiche

Tenere sempre a mente che PartitionManager non può operare su partizioni montate, oppure presenti sul disco rigido su cui risiede la propria installazione di Kubuntu.

In questi casi, avviare una LiveUSB o LiveDVD di Kubuntu.

Per familiarizzare con la terminologia delle partizioni, conoscere le caratteristiche e scegliere quelle più appropriate per le proprie necessità leggere la guida Partizioni.

Per creare manualmente la tabella delle partizioni leggere la guida Tabella delle partizioni.

Installazione

Il programma è preinstallato in Kubuntu, nel caso fosse stato rimosso installare il pacchetto partitionmanager

PartitionManager supporta numerosi tipi di file system, tramite l'installazione dei pacchetti coi programmi necessari per gestire i corrispondenti file system.

Pacchetti nel repository

Installare il pacchetto corrispondente al file system come da seguente tabella:

File system

Pacchetto richiesto

btrfs

btrfs

exfat

exfat-utils

ext2

e2fsprogs

ext3

e2fsprogs

ext4

e2fsprogs

f2fs

f2fs-tools

fat12

dosfstools (solo 20.04)

fat16

dosfstools

fat32

dosfstools

hfs

hfsutils

hfsplus

hfsplus

hpfs

ntfs-3g

jfs

jfsutils

linux-swap

util-linux

lvm2 pv

lvm2

nilfs2

nilfs-utils

ntfs

ntfs-3g

ocfs2

ocfs2-tools

reiser4

reiser4progs

reiserfs

reiser4progs

xfs

xfsprogs + xfsdump

zfs

zfsutils-linux

Pacchetti da terze parti

Il pacchetto col programma per supportare il filesystem ufs, usualmente usato con GNU/kFreeBSD e simili, non è più presente nei repository ma in caso di necessità si può scaricare e installare una versione obsoleta da Launchpad.

Per scaricare e installare il pacchetto ufsutils digitare nel terminale i seguenti comandi:

wget https://launchpad.net/ubuntu/+archive/primary/+files/ufsutils_8.2-3_amd64.deb
sudo dpkg -i ufsutils_8.2-3_amd64.deb

Per verificare quali file system sono supportati e quali opzioni offrono, avviare il programma e selezionare il menù Strumenti → File system Supportati.

Avvio del programma

  • Avviare il programma PartitionManager.

  • Scegliere il disco rigido su cui operare nel pannello a sinistra, se non mostrato selezionare il menù Impostazioni → Pannelli mostrati → Dispositivi.

  • Facoltativamente verificare l'integrità fisica del disco rigido selezionando il menù Dispositivo → Stato SMART.

  • Fare clic con il tasto destro sulla partizione o spazio non allocato, su cui si desidera operare e selezionare l'opzione Smonta.

Ora sarà possibile eseguire le operazioni desiderate.

Partizioni

Il numero di partizioni varia a seconda del tipo di tabella delle partizioni in uso o da impostare.

Nel caso di disco rigido nuovo o cancellato totalmente, preventivamente è necessario creare la tabella delle partizioni.

Tabella delle partizioni

  1. Selezionare il menù Dispositivo → Nuova tabella delle partizioni.

  2. Alla voce Scegli il tipo di tabella delle partizioni che vuoi creare mettere la spunta rispettivamente a MS-Dos o GPT, in funzione se il sistema è BIOS o UEFI.

  3. Fare clic su Crea nuova tabella delle partizioni.

Partizionare sistema MBR

Lo standard MBR limita il numero di partizioni primarie a 4. La creazione viene trattata nel paragrafo Partizione primaria.

Per superare questa limitazione una delle 4 partizioni primarie deve essere creata come estesa, poi al suo interno sarà possibile creare svariate partizioni logiche. La creazione viene trattata nel paragrafo Partizione estesa e logica.

Partizionare sistema GPT

Lo standard GPT non ha limite di numero di partizioni primarie. La creazione viene trattata nel paragrafo Partizione primaria.

Nel caso di disco rigido nuovo o cancellato totalmente, preventivamente è necessario creare una partizione EFI di boot.

Partizione EFI

Nell'immagine si va a ritagliare nello spazio non allocato una porzione da 500MB, da destinare alla partizione EFI.

Fare clic col destro sulla partizione e selezionare Nuova, scrivere nella casella Dimensione: la dimensione richiesta, nella casella File system selezionare fat32.

Fare quindi clic su OK.

Partizione primaria

Nell'immagine si va a sottrarre spazio alla partizione /dev/sdc1 in formato ext4, per creare lo spazio non allocato in cui creare la nuova partizione primaria.

Fare clic col destro sulla partizione e selezionare Ridimensiona/Sposta, scrivere nella casella Dimensione: lo spazio da lasciare alla partizione esistente mentre nella casella Spazio libero dopo: la dimensione dello spazio.

Fare quindi clic su OK.

Nell'immagine si va a creare la partizione primaria /dev/sdc2 nello spazio non allocato.

Fare clic col destro sullo spazio non allocato e selezionare Nuova, scrivere nella casella Dimensione: la dimensione richiesta, nella casella File system selezionare ext4.

Fare quindi clic su OK.

Nell'immagine è mostrata la nuova situazione con la partizione /dev/sdc1 ridimensionata e lo spazio non allocato nel quale è stata creata la partizione /dev/sdc2.

Partizione estesa e logica

Nell'immagine si va a sottrarre spazio alla partizione primaria /dev/sdc3 in formato ext4 per creare lo spazio non allocato in cui creare la partizione estesa.

Fare clic col destro sulla partizione e selezionare Ridimensiona/Sposta, scrivere nella casella Dimensione: lo spazio da lasciare alla partizione esistente mentre nella casella Spazio libero dopo: la dimensione dello spazio in cui creare la partizione estesa.

Fare quindi clic su OK.

Fare clic col destro sullo spazio non allocato e selezionare Nuova, mettere la spunta su Estesa.

Fare quindi clic su OK.

Nell'immagine si va a creare le partizioni logiche all'interno della partizione estesa, con le stesse modalità delle partizioni primarie con il limite di potere selezionare solo Partizione logica.

Nell'immagine è mostrata la nuova situazione con la partizione /dev/sdc3 ridimensionata seguita dalla partizione /dev/sdc4 estesa e dalle partizioni /dev/sdc5 e /dev/sdc6 logiche.

Nome etichetta partizione

In caso siano presenti molte partizioni, può diventare difficile riconoscerle. Per distingure le partizioni è possibile dare un nome univoco a ciascuna.

  • Avviare il programma PartitionManager.

  • Scegliere il disco rigido su cui operare nel pannello a sinistra, se non mostrato selezionare il menù Impostazioni → Pannelli mostrati → Dispositivi.

  • Fare clic con il tasto destro sulla partizione su cui si desidera operare e selezionare l'opzione Smonta.

  • Rifare clic con il tasto destro sulla partizione che si desidera nominare e selezionare Proprietà.

  • Scrivere il nome scelto nella casella Etichetta:.

  • Fare clic sull'icona Applica presente nella barra menù.

Backup

PartitionManager può creare un file immagine integrale non compresso d'ogni partizione utile come backup, e ripristinare dal file immagine archiviato la corrispondente partizione danneggiata.

Questa funzione necessita di un secondo rigido esterno di capacità maggiore di circa il 10% della partizione salvata, ad esempio il file immagine di backup d'una partizione di 40 GB necessita d'almeno 44 GB.

Il ripristino della partizione dal file immagine sovrascriverà ogni dato presente cancellandolo. Se vi sono dati da conservare, prima recuperare i dati d'interesse tramite una LiveUSB o LiveDVD di Kubuntu, e poi procedere al ripristino.

Salvataggio

  • Scegliere il disco rigido su cui operare nella finestra a sinistra, se non mostrata selezionare il menù Visualizza → Dispositivi.

  • Fare clic con il tasto destro sulla partizione da salvare e selezionare il menù Partizione → Copia di sicurezza.

  • Alla richiesta selezionare la locazione ove archiviare il file immagine.
  • Attendere la fine della procedura.

Ripristino

  • Scegliere il disco rigido su cui operare nella finestra a sinistra, se non mostrata selezionare il menù Visualizza → Dispositivi.

  • Fare clic con il tasto destro sulla partizione da ripristinare e selezionare il menù Partizione → Ripristina.

  • Alla richiesta selezionare la locazione e il nome del file immagine.
  • Attendere la fine della procedura.

Ulteriori risorse

CategoryAmministrazione CategoryHardware