Wiki Ubuntu-it

Indice
Partecipa
FAQ
Wiki Blog
------------------
Ubuntu-it.org
Forum
Chiedi
Chat
Cerca
Planet
  • Immutable Page
  • Info
  • Attachments
  • Diff for "Repository/SourcesList/EOL"
Differences between revisions 6 and 7
Revision 6 as of 08/02/2012 11.39.55
Size: 15411
Comment:
Revision 7 as of 08/02/2012 14.39.34
Size: 4777
Comment:
Deletions are marked like this. Additions are marked like this.
Line 9: Line 9:
I rilasci di '''Ubuntu''' vengono supportati normalmente per 18 mesi mentre per le versioni '''LTS''' (Long Term Support) questo supporto si estendeva a 3 anni per le versioni desktop e 5 anni per le versioni server. A partire da '''Precise Pangolin''' entrambe le versioni '''LTS''' sono supportate per 5 anni. Quando un rilascio perde il supporto i suoi repository standard vengono messi off-line e non sarà più possibile usarli per il download dei programmi tramite [[AmministrazioneSistema/InstallareProgrammi#Installare_pacchetti_da_repository|gestore di pacchetti]], inoltre, cosa più importante, non verranno più rilasciati aggiornamenti di sicurezza nè fix di alcun genere.
Tuttavia quando una versione di '''Ubuntu''' esce dal ciclo di supporto, i repository vengono spostati sul server [[http://old-releases.ubuntu.com]] grazie al quale è possibile continuare ad usare il proprio gestore di pacchetti.
Questa pagina contiene esempi di file `/etc/apt/sources.list` per le vecchie versioni di '''Ubuntu'''. Sono attivi i [[Repository/Componenti|componenti]] '''main''', '''restricted''', '''universe''', '''multiverse''' e gli aggiornamenti normali e quelli di sicurezza fino alla loro ultima versione resa disponibile.
Le versioni di Ubuntu che hanno raggiunto il termine del loro ciclo di supporto, non ricevono più aggiornamenti di sicurezza e di bug fixing. Quando un rilascio perde il supporto i suoi [[Repository|repository]] vengono trasferiti sul server [[http://old-releases.ubuntu.com|old-releases.ubuntu.com]].
Line 13: Line 11:
||<tablestyle="text-align: justify; width:50%;" style="border:none;" 5%><<Immagine(Icone/Piccole/warning.png,,center)>> ||<style="padding:0.5em; border:none;">'''Usare una versione non supportata potrebbe apportare rischi di sicurezza, se possibile, si consiglia di aggiornare Ubuntu''' || ||<tablestyle="text-align: justify; width:60%;" style="border:none;" 5%><<Immagine(Icone/Piccole/warning.png,,center)>> ||<style="padding:0.5em; border:none;">'''Si ricorda che proprio per l'assenza di aggiornamenti di sicurezza e di bug fixing, l'utilizzo di versioni non più supportate è altamente sconsigliato.''' ||
Line 15: Line 13:
Perché il gestore dei pacchetti possa essere ancora utilizzabile occorre quindi modificare i repository come indicato in questa pagina. Questo si rende assolutamente necessario per poter [[Installazione/NoteAvanzamento|aggiornare]] il sistema operativo.

<<Anchor(codename)>>
Line 17: Line 18:
 * Digitare il seguente comando in una finestra di [[AmministrazioneSistema/RigaDiComando|terminale]]:
{{{
 0. Digitare il seguente comando in una finestra di [[AmministrazioneSistema/RigaDiComando|terminale]]:{{{
Line 21: Line 21:
 * Il risultato sarà simile a quanto segue:
{{{
 0. Il risultato sarà simile a quanto segue:{{{
Line 27: Line 26:
 * In alternativa digitare
{{{
cat /etc/issue
}}}
 * Il risultato ottenuto sarà simile a
{{{
Ubuntu 9.10 \n \l
}}}
Il dato fondamentale da ricavare lo si ha alla voce '''''Codename''''' che dovrà essere sostituito nel file `/etc/apt/sources.list` come mostrato di seguito.<<BR>>
In questo esempio risulta essere '''karmic''', nome in codice della versione 9.10 di Ubuntu.
Line 38: Line 31:
 0. Aprire con i [[AmministrazioneSistema/Sudo|privilegi di amministrazione]] e con un [[Ufficio/EditorDiTesto|editor di testo]] il file `/etc/apt/sources.list` e cancellare l'intero contenuto. Aprire con i [[AmministrazioneSistema/Sudo|privilegi di amministrazione]] e con un [[Ufficio/EditorDiTesto|editor di testo]] il file `/etc/apt/sources.list` e cancellare l'intero contenuto.
Line 40: Line 33:
 0. Inserire i repository desiderati come da esempio avendo cura di sotituire CODENAME col nome in codice della versione '''Ubuntu''' in uso:  Occorre inserire i repository desiderati come da esempio, avendo cura di sotituire CODENAME col nome in codice della versione '''Ubuntu''' ricavato nel passaggio precedente:
Line 42: Line 36:
Line 53: Line 46:
 * '''Repository aggiuntivi''': === Repository aggiuntivi ===
Line 55: Line 48:
 * '''Backports''':  {{{  * '''Backports''':{{{
Line 60: Line 52:

* '''Proposed''':  {{{
 * '''Proposed''':{{{
Line 67: Line 57:
 0. Salvare e chiudere l'editor di testo

0. Aggiornare l'elenco dei sorgenti digitando in una finestra di [[AmministrazioneSistema/RigaDiComando|terminale]]
Salvare e chiudere l'editor di testo e quindi aggiornare l'elenco dei sorgenti digitando in una finestra di [[AmministrazioneSistema/RigaDiComando|terminale]]:
Line 75: Line 62:
= Esempio =
Line 76: Line 64:
A titolo esemplificativo, se come nel [[#codename|passaggio iniziale]] il nome della versione in uso risultasse '''karmic''', allora il file verrebbe così modificato:
Line 77: Line 66:
{{{
deb http://old-releases.ubuntu.com/ubuntu/ karmic main universe restricted multiverse
deb-src http://old-releases.ubuntu.com/ubuntu/ karmic main universe restricted multiverse
Line 78: Line 70:
##= Ubuntu 9.10 «Karmic Koala» = deb http://old-releases.ubuntu.com/ubuntu/ karmic-security main universe restricted multiverse
deb-src http://old-releases.ubuntu.com/ubuntu/ karmic-security main universe restricted multiverse
Line 80: Line 73:
##{{{
##
deb http://old-releases.ubuntu.com/ubuntu/ karmic main universe restricted multiverse
##deb-src http://old-releases.ubuntu.com/ubuntu/ karmic main universe restricted multiverse
deb http://old-releases.ubuntu.com/ubuntu/ karmic-updates main universe restricted multiverse
deb-src http://old-releases.ubuntu.com/ubuntu/ karmic-updates main universe restricted multiverse
}}}
Line 84: Line 77:
##deb http://old-releases.ubuntu.com/ubuntu/ karmic-security main universe restricted multiverse
##deb-src http://old-releases.ubuntu.com/ubuntu/ karmic-security main universe restricted multiverse
=== Repository aggiuntivi ===
Line 87: Line 79:
##deb http://old-releases.ubuntu.com/ubuntu/ karmic-updates main universe restricted multiverse
##deb-src http://old-releases.ubuntu.com/ubuntu/ karmic-updates main universe restricted multiverse
##}}}
 * '''Backports''':{{{
deb http://old-releases.ubuntu.com/ubuntu/ karmic-backports main restricted universe multiverse
deb-src http://old-releases.ubuntu.com/ubuntu/ karmic-backports main restricted universe multiverse
}}}
Line 91: Line 84:
##== Repository aggiuntivi ==

## * '''Backports''': {{{
##deb http://old-releases.ubuntu.com/ubuntu/ karmic-backports main restricted universe multiverse
##deb-src http://old-releases.ubuntu.com/ubuntu/ karmic-backports main restricted universe multiverse
##}}}

## * '''Proposed''': {{{
##deb http://old-releases.ubuntu.com/ubuntu/ karmic-proposed main restricted universe multiverse
##deb-src http://old-releases.ubuntu.com/ubuntu/ karmic-proposed main restricted universe multiverse
##}}}

##= Ubuntu 9.04 «Jaunty Jackalope» =

##{{{
##deb http://old-releases.ubuntu.com/ubuntu/ jaunty main universe restricted multiverse
##deb-src http://old-releases.ubuntu.com/ubuntu/ jaunty main universe restricted multiverse

##deb http://old-releases.ubuntu.com/ubuntu/ jaunty-security main universe restricted multiverse
##deb-src http://old-releases.ubuntu.com/ubuntu/ jaunty-security main universe restricted multiverse

##deb http://old-releases.ubuntu.com/ubuntu/ jaunty-updates main universe restricted multiverse
##deb-src http://old-releases.ubuntu.com/ubuntu/ jaunty-updates main universe restricted multiverse
##}}}

##== Repository aggiuntivi ==

## * '''Backports''': {{{
##deb http://old-releases.ubuntu.com/ubuntu/ jaunty-backports main restricted universe multiverse
##deb-src http://old-releases.ubuntu.com/ubuntu/ jaunty-backports main restricted universe multiverse
##}}}

## * '''Proposed''': {{{
##deb http://old-releases.ubuntu.com/ubuntu/ jaunty-proposed main restricted universe multiverse
##deb-src http://old-releases.ubuntu.com/ubuntu/ jaunty-proposed main restricted universe multiverse
##}}}

##= Ubuntu 8.10 «Intrepid Ibex» =

##{{{
##deb http://old-releases.ubuntu.com/ubuntu/ intrepid main universe restricted multiverse
##deb-src http://old-releases.ubuntu.com/ubuntu/ intrepid main universe restricted multiverse

##deb http://old-releases.ubuntu.com/ubuntu/ intrepid-security main universe restricted multiverse
##deb-src http://old-releases.ubuntu.com/ubuntu/ intrepid-security main universe restricted multiverse

##deb http://old-releases.ubuntu.com/ubuntu/ intrepid-updates main universe restricted multiverse
##deb-src http://old-releases.ubuntu.com/ubuntu/ intrepid-updates main universe restricted multiverse
##}}}

##== Repository aggiuntivi ==

## * '''Backports''': {{{
##deb http://old-releases.ubuntu.com/ubuntu/ intrepid-backports main restricted universe multiverse
##deb-src http://old-releases.ubuntu.com/ubuntu/ intrepid-backports main restricted universe multiverse
##}}}

## * '''Proposed''': {{{
##deb http://old-releases.ubuntu.com/ubuntu/ intrepid-proposed main restricted universe multiverse
##deb-src http://old-releases.ubuntu.com/ubuntu/ intrepid-proposed main restricted universe multiverse
##}}}

##= Ubuntu 7.10 «Gutsy Gibbon» =

##{{{
##deb http://old-releases.ubuntu.com/ubuntu/ gutsy main universe restricted multiverse
##deb-src http://old-releases.ubuntu.com/ubuntu/ gutsy main universe restricted multiverse

##deb http://old-releases.ubuntu.com/ubuntu/ gutsy-security main universe restricted multiverse
##deb-src http://old-releases.ubuntu.com/ubuntu/ gutsy-security main universe restricted multiverse

##deb http://old-releases.ubuntu.com/ubuntu/ gutsy-updates main universe restricted multiverse
##deb-src http://old-releases.ubuntu.com/ubuntu/ gutsy-updates main universe restricted multiverse
##}}}

##== Repository aggiuntivi ==

## * '''Backports''': {{{
##deb http://old-releases.ubuntu.com/ubuntu/ gutsy-backports main restricted universe multiverse
##deb-src http://old-releases.ubuntu.com/ubuntu/ gutsy-backports main restricted universe multiverse
##}}}

## * '''Proposed''': {{{
##deb http://old-releases.ubuntu.com/ubuntu/ gutsy-proposed main restricted universe multiverse
##deb-src http://old-releases.ubuntu.com/ubuntu/ gutsy-proposed main restricted universe multiverse
##}}}

##= Ubuntu 7.04 «Feisty Fawn» =

##{{{
##deb http://old-releases.ubuntu.com/ubuntu/ feisty main universe restricted multiverse
##deb-src http://old-releases.ubuntu.com/ubuntu/ feisty main universe restricted multiverse

##deb http://old-releases.ubuntu.com/ubuntu/ feisty-security main universe restricted multiverse
##deb-src http://old-releases.ubuntu.com/ubuntu/ feisty-security main universe restricted multiverse

##deb http://old-releases.ubuntu.com/ubuntu/ feisty-updates main universe restricted multiverse
##deb-src http://old-releases.ubuntu.com/ubuntu/ feisty-updates main universe restricted multiverse
##}}}

##== Repository aggiuntivi ==

## * '''Backports''': {{{
##deb http://old-releases.ubuntu.com/ubuntu/ feisty-backports main restricted universe multiverse
##deb-src http://old-releases.ubuntu.com/ubuntu/ feisty-backports main restricted universe multiverse
##}}}

## * '''Proposed''': {{{
##deb http://old-releases.ubuntu.com/ubuntu/ feisty-proposed main restricted universe multiverse
##deb-src http://old-releases.ubuntu.com/ubuntu/ feisty-proposed main restricted universe multiverse
##}}}

##= Ubuntu 6.10 «Edgy Eft» =

##{{{
##deb http://old-releases.ubuntu.com/ubuntu/ edgy main universe restricted multiverse
##deb-src http://old-releases.ubuntu.com/ubuntu/ edgy main universe restricted multiverse

##deb http://old-releases.ubuntu.com/ubuntu/ edgy-security main universe restricted multiverse
##deb-src http://old-releases.ubuntu.com/ubuntu/ edgy-security main universe restricted multiverse

##deb http://old-releases.ubuntu.com/ubuntu/ edgy-updates main universe restricted multiverse
##deb-src http://old-releases.ubuntu.com/ubuntu/ edgy-updates main universe restricted multiverse
##}}}

== Repository aggiuntivi ==

## * '''Backports''': {{{
##deb http://old-releases.ubuntu.com/ubuntu/ edgy-backports main restricted universe multiverse
##deb-src http://old-releases.ubuntu.com/ubuntu/ edgy-backports main restricted universe multiverse
##}}}

## * '''Proposed''': {{{
##deb http://old-releases.ubuntu.com/ubuntu/ edgy-proposed main restricted universe multiverse
##deb-src http://old-releases.ubuntu.com/ubuntu/ edgy-proposed main restricted universe multiverse
##}}}

##= Ubuntu 6.06 «Dapper Drake» =

##{{{
##deb http://old-releases.ubuntu.com/ubuntu/ dapper main universe restricted multiverse
##deb-src http://old-releases.ubuntu.com/ubuntu/ dapper main universe restricted multiverse

##deb http://old-releases.ubuntu.com/ubuntu/ dapper-security main universe restricted multiverse
##deb-src http://old-releases.ubuntu.com/ubuntu/ dapper-security main universe restricted multiverse

##deb http://old-releases.ubuntu.com/ubuntu/ dapper-updates main universe restricted multiverse
##deb-src http://old-releases.ubuntu.com/ubuntu/ dapper-updates main universe restricted multiverse
##}}}

##== Repository aggiuntivi ==

## * '''Backports''': {{{
##deb http://old-releases.ubuntu.com/ubuntu/ dapper-backports main restricted universe multiverse
##deb-src http://old-releases.ubuntu.com/ubuntu/ dapper-backports main restricted universe multiverse
##}}}

## * '''Proposed''': {{{
##deb http://old-releases.ubuntu.com/ubuntu/ dapper-proposed main restricted universe multiverse
##deb-src http://old-releases.ubuntu.com/ubuntu/ dapper-proposed main restricted universe multiverse
##}}}

##= Ubuntu 5.10 «Breezy Badger» =

##{{{
##deb http://old-releases.ubuntu.com/ubuntu/ breezy main universe restricted multiverse
##deb-src http://old-releases.ubuntu.com/ubuntu/ breezy main universe restricted multiverse

##deb http://old-releases.ubuntu.com/ubuntu/ breezy-security main universe restricted multiverse
##deb-src http://old-releases.ubuntu.com/ubuntu/ breezy-security main universe restricted multiverse

##deb http://old-releases.ubuntu.com/ubuntu/ breezy-updates main universe restricted multiverse
##deb-src http://old-releases.ubuntu.com/ubuntu/ breezy-updates main universe restricted multiverse
##}}}

##== Repository aggiuntivi ==

## * '''Backports''': {{{
##deb http://old-releases.ubuntu.com/ubuntu/ breezy-backports main restricted universe multiverse
##deb-src http://old-releases.ubuntu.com/ubuntu/ breezy-backports main restricted universe multiverse
##}}}

## * '''Proposed''': {{{
##deb http://old-releases.ubuntu.com/ubuntu/ breezy-proposed main restricted universe multiverse
##deb-src http://old-releases.ubuntu.com/ubuntu/ breezy-proposed main restricted universe multiverse
##}}}

##= Ubuntu 5.04 «Hoary Hedgehog» =

##{{{
##deb http://old-releases.ubuntu.com/ubuntu/ hoary main universe restricted multiverse
##deb-src http://old-releases.ubuntu.com/ubuntu/ hoary main universe restricted multiverse

##deb http://old-releases.ubuntu.com/ubuntu/ hoary-security main universe restricted multiverse
##deb-src http://old-releases.ubuntu.com/ubuntu/ hoary-security main universe restricted multiverse

##deb http://old-releases.ubuntu.com/ubuntu/ hoary-updates main universe restricted multiverse
##deb-src http://old-releases.ubuntu.com/ubuntu/ hoary-updates main universe restricted multiverse
##}}}

##== Repository aggiuntivi ==

## * '''Backports''': {{{
##deb http://old-releases.ubuntu.com/ubuntu/ hoary-backports main restricted universe multiverse
##deb-src http://old-releases.ubuntu.com/ubuntu/ hoary-backports main restricted universe multiverse
##}}}

## * '''Proposed''': {{{
##deb http://old-releases.ubuntu.com/ubuntu/ hoary-proposed main restricted universe multiverse
##deb-src http://old-releases.ubuntu.com/ubuntu/ hoary-proposed main restricted universe multiverse
##}}}

##= Ubuntu 4.10 «Warty Warthog» =

##{{{
##deb http://old-releases.ubuntu.com/ubuntu/ warty main universe restricted multiverse
##deb-src http://old-releases.ubuntu.com/ubuntu/ warty main universe restricted multiverse

##deb http://old-releases.ubuntu.com/ubuntu/ warty-security main universe restricted multiverse
##deb-src http://old-releases.ubuntu.com/ubuntu/ warty-security main universe restricted multiverse

##deb http://old-releases.ubuntu.com/ubuntu/ warty-updates main universe restricted multiverse
##deb-src http://old-releases.ubuntu.com/ubuntu/ warty-updates main universe restricted multiverse
##}}}

##== Repository aggiuntivi ==

## * '''Backports''': {{{
##deb http://old-releases.ubuntu.com/ubuntu/ warty-backports main restricted universe multiverse
##deb-src http://old-releases.ubuntu.com/ubuntu/ warty-backports main restricted universe multiverse
##}}}

## * '''Proposed''': {{{
##deb http://old-releases.ubuntu.com/ubuntu/ warty-proposed main restricted universe multiverse
##deb-src http://old-releases.ubuntu.com/ubuntu/ warty-proposed main restricted universe multiverse
##}}}
 * '''Proposed''':{{{
deb http://old-releases.ubuntu.com/ubuntu/ karmic-proposed main restricted universe multiverse
deb-src http://old-releases.ubuntu.com/ubuntu/ karmic-proposed main restricted universe multiverse
}}}


Problemi in questa pagina? Segnalali in questa discussione

Introduzione

Le versioni di Ubuntu che hanno raggiunto il termine del loro ciclo di supporto, non ricevono più aggiornamenti di sicurezza e di bug fixing. Quando un rilascio perde il supporto i suoi repository vengono trasferiti sul server old-releases.ubuntu.com.

Si ricorda che proprio per l'assenza di aggiornamenti di sicurezza e di bug fixing, l'utilizzo di versioni non più supportate è altamente sconsigliato.

Perché il gestore dei pacchetti possa essere ancora utilizzabile occorre quindi modificare i repository come indicato in questa pagina. Questo si rende assolutamente necessario per poter aggiornare il sistema operativo.

Individuare la propria versione

  1. Digitare il seguente comando in una finestra di terminale:

    lsb_release -dc
  2. Il risultato sarà simile a quanto segue:

    Description:    Ubuntu 9.10
    Codename:       karmic

Il dato fondamentale da ricavare lo si ha alla voce Codename che dovrà essere sostituito nel file /etc/apt/sources.list come mostrato di seguito.
In questo esempio risulta essere karmic, nome in codice della versione 9.10 di Ubuntu.

Sostituire i repository

Aprire con i privilegi di amministrazione e con un editor di testo il file /etc/apt/sources.list e cancellare l'intero contenuto.

Occorre inserire i repository desiderati come da esempio, avendo cura di sotituire CODENAME col nome in codice della versione Ubuntu ricavato nel passaggio precedente:

deb http://old-releases.ubuntu.com/ubuntu/ CODENAME main universe restricted multiverse
deb-src http://old-releases.ubuntu.com/ubuntu/ CODENAME main universe restricted multiverse

deb http://old-releases.ubuntu.com/ubuntu/ CODENAME-security main universe restricted multiverse
deb-src http://old-releases.ubuntu.com/ubuntu/ CODENAME-security main universe restricted multiverse

deb http://old-releases.ubuntu.com/ubuntu/ CODENAME-updates main universe restricted multiverse
deb-src http://old-releases.ubuntu.com/ubuntu/ CODENAME-updates main universe restricted multiverse

Repository aggiuntivi

  • Backports:

    deb http://old-releases.ubuntu.com/ubuntu/ CODENAME-backports main restricted universe multiverse
    deb-src http://old-releases.ubuntu.com/ubuntu/ CODENAME-backports main restricted universe multiverse
  • Proposed:

    deb http://old-releases.ubuntu.com/ubuntu/ CODENAME-proposed main restricted universe multiverse
    deb-src http://old-releases.ubuntu.com/ubuntu/ CODENAME-proposed main restricted universe multiverse

Salvare e chiudere l'editor di testo e quindi aggiornare l'elenco dei sorgenti digitando in una finestra di terminale:

sudo apt-get update

Esempio

A titolo esemplificativo, se come nel passaggio iniziale il nome della versione in uso risultasse karmic, allora il file verrebbe così modificato:

deb http://old-releases.ubuntu.com/ubuntu/ karmic main universe restricted multiverse
deb-src http://old-releases.ubuntu.com/ubuntu/ karmic main universe restricted multiverse

deb http://old-releases.ubuntu.com/ubuntu/ karmic-security main universe restricted multiverse
deb-src http://old-releases.ubuntu.com/ubuntu/ karmic-security main universe restricted multiverse

deb http://old-releases.ubuntu.com/ubuntu/ karmic-updates main universe restricted multiverse
deb-src http://old-releases.ubuntu.com/ubuntu/ karmic-updates main universe restricted multiverse

Repository aggiuntivi

  • Backports:

    deb http://old-releases.ubuntu.com/ubuntu/ karmic-backports main restricted universe multiverse
    deb-src http://old-releases.ubuntu.com/ubuntu/ karmic-backports main restricted universe multiverse
  • Proposed:

    deb http://old-releases.ubuntu.com/ubuntu/ karmic-proposed main restricted universe multiverse
    deb-src http://old-releases.ubuntu.com/ubuntu/ karmic-proposed main restricted universe multiverse

Ulteriori risorse



CategoryNuoviDocumenti