Wiki Ubuntu-it

Indice
Partecipa
FAQ
Wiki Blog
------------------
Ubuntu-it.org
Forum
Chiedi
Chat
Cerca
Planet
  • Immutable Page
  • Info
  • Attachments


Problemi in questa pagina? Segnalali in questa discussione

Introduzione

Eclipse è un ambiente di sviluppo integrato, sviluppato in passato da IBM e successivamente preso in gestione da Eclipse Foundation che si occupa tutt'ora del suo sviluppo.

Installazione

Installazione da Gestore pacchetti

Installare il pacchetto eclipse.

Per tradurre in italiano un'installazione di Eclipse occorre seguire i passaggi del paragrafo localizzazione.

La versione di Eclipse presente nelle sorgenti software non è sempre aggiornata, per ottenere l'ultima versione è possibile optare per l'installazione manuale.

Installazione manuale

  1. Installare il pacchetto gcj-jre.

  2. Scaricare nella propria Home l'archivio compresso presente a questo indirizzo.

  3. Spostare il file scaricato nella cartella /opt digitando il seguente comando in una finestra di terminale:

    sudo mv FILE_SCARICATO.tar.gz /opt
    sostituire la dicitura «FILE_SCARICATO.tar.gz» con il nome del file scaricato.
  4. Scompattare l'archivio digitando i seguenti comandi:

    cd /opt
    sudo tar -xvf [FILE_SCARICATO].tar.gz
  5. Cambiare i permessi alla cartella di Eclipse digitando:

    sudo chown -R root:root /opt/eclipse 

Con la versione 3.6 (Helios) questa procedura può causare problemi all'installazione dei plugin. Ciò può essere risolto cambiando permessi su file e cartelle sull'utente user invece del root (bug 317896).

Per avviare Eclipse in un modo più semplice è stato scritto uno script di avvio, per installarlo procedere come segue:

Creare con un editor di testo e i privilegi di amministratore il file /usr/local/bin/eclipse ed incollarvi dentro le seguenti righe:

 #!/bin/bash
export MOZILLA_FIVE_HOME="/usr/lib/firefox/"
export ECLIPSE_HOME="/opt/eclipse"
/opt/eclipse/eclipse

Per rendere lo script eseguibile digitare il comando:

sudo chmod +x /usr/local/bin/eclipse

Per avviare Eclipse digitare in una finestra di terminale:

eclipse

Se si riceve l'errore:

Problems opening page

eliminare le righe contenenti export dal precedente script.

Localizzazione

Se si è scelta l'installazione manuale, scaricare nella cartella di installazione di Eclipse il pacchetto NLpack1-eclipse-SDK-3.2-gtk.zip e scompattarlo.

Per avviare Eclipse in lingua italiana digitare il comando:

eclipse -nl it_IT

Questi parametri possono essere aggiunti allo script di avvio visto nel paragrafo precedente.

Plugin

Per installare un plugin occorre semplicemente scompattarlo nella cartella di installazione del programma. Quando si è installato il programma tramite i repository di Ubuntu è presente una cartella contenente i plugin in /usr/lib/eclipse/. Normalmente Eclipse rileva automaticamente i plugin affinché possano essere utilizzati dall'utente.

In un'installazione manuale di Eclipse i plugin possono essere installati avviando il gestore degli aggiornamenti con i diritti amministrativi. Di seguito è proposto l'esempio su come installare il plugin phpeclipse.

Phpeclipse

Per gli sviluppatori di linguaggio PHP esiste il pluginche funziona con l'opzionale debugger DBG.

Se qui è regolarmente in crash, Eclipse dovrebbe essere avviato direttamente da file jar con il comando:

java -jar /usr/lib/eclipse/startup.jar 

Di seguito sono riportate le istruzioni per installare il plugin Phpeclipse.

  1. Selezionare Guida → Aggiornamenti software → Trova e installa... per avviare il gestore degli aggiornamenti.

  2. Scegliere «"Search for new features to install"»

  3. Creare un «"New remote site"» ed inserire nel campo Name la stringa PHPEclipse 1.2.x, inserire

    http://update.phpeclipse.net/update/stable/1.2.x
    nel campo URL e dare OK.
  4. Verificare che PHPEclipse 1.2.x si selezionato e fare clic su «"Finish"»

  5. «"Next"»

Il processo di installazione può causare problemi se vi sono meno di 512 MiB di ram disponibili.

Dopo aver installato un plugin attraverso «" Aggiornamenti software"» i permessi di file e cartella in /opt/eclipse devono essere risistemati. Le nuove cartelle dei plugin devono essere esplorabili da ciascun utente e i file devonono essere letti da ogni utente:

sudo find /opt/eclipse/ -type d -exec chmod o+rx {} \;
sudo find /opt/eclipse/ -type f -exec chmod o+r {} \; 

Aptana

Aptana è un plugin per lo sviluppo web con Eclipse. Aptana aiuta nella creazione di codice sorgente in PHP, HTML e Javascript.

CDT

Per utilizzare Eclipse nello sviluppo di applicazioni nei linguaggi C e C++

Installazione da Gestore pacchetti

A partire da Ubuntu 10.10 è sufficiente installare i pacchetti eclipse-cdt e g++.

Installazione da Aggiornamenti software

  1. Assicurarsi che i pacchetti eclipse e g++ siano installati.

  2. Avviare Eclipse ed andare su Window → Preferences → Install / Update → Available Software

  3. Qui aggiungere una nuova sorgente software con il tasto sinistro del mouse Add.

  4. Dare un nome alla seguente sorgente ed aggiungerla (il nome è arbitrario):

    http://download.eclipse.org/tools/cdt/releases/galileo
  5. La finestra popup verrà chiusa e in Help → Install New Software → work with selezionare la sorgente recentemente aggiunta.

  6. Adesso CDT Main Features è selezionata. Clic sul pulsante «"Next"» per installare.

PST

PST è un plugin per lo sviluppo in PHP. Per installarlo basta andare su Help → Install New Software.

ecletex/texlipse

ecletex e texlipse sono plugin per lavorare con LaTeX. Espandono la funzionalità dell'editor di Eclipse con la'abilità di modificare file in 'LaTeX.

PyDev

PyDev è un Python IDE per Eclipse. Sotto Window → Preferences → PyDev → Interpreter - Python aggiungere come percorso /usr/bin/python per l'interprete del Python.

Subclipse

Usando Subclipse è possibile utilizzare direttamente i repository di subversion. L'installazione è semplice, vedere: Istruzioni di installazione

Se la voce dl menù Preference' di Subclipse si avvia con un messaggio di errore, le librerie necessarie vanno installate a mano e copiate nella cartella di Eclipse.

Installare il pacchetto libsvn-java

Copiare allora la libreria libsvnjavah-1.so:

sudo cp / usr/lib/jni/libsvnjavahl-1.so [percorso della cartella di Eclipse ]/jre/lib/i386/libsvnjavahl-1.so 

Se il messaggio di errore "Unable to load default SVN Client" vive mostrato assicurarsi che il pacchetto libsvn-java sia installatoe e se ancora eclipse.ini deve essere sistemato.

Se appare il messaggio di errore di sopra, è necessario aggiungere le seguenti righe nel file eclipse.ini:

   -Djava.library.path=/usr/share/java/
   -Djava.library.path=/usr/lib/jni/ 

PovClipse

PovClipse è un plugin dell'editor di Eclipse per Povray (Persistence of Vision)

Versioni di Java

Java VM per Eclipse

Lo stesso Eclipse è scritto in Java e richiede una Java virtual machine. Come predefinito Eclipse si avvierà con GIJ.Se sul proprio sistema si è installato il JDK di Sun , per esempio, si preferirebbe che Eclipse giri su Sun virtual machine. Per ottenere ciò fare come è spiegato di seguito.

  • Impostare la Java virtual machine sul file eclipse.ini come spiegato nel wiki di Eclipse.

  • Passare la chiamata alla Java virtual machine di Eclipse come parametro, ad esempio:

    /usr/bin/eclipse -vm /usr/lib/jvm/java-1.5.0-sun-1.5.0.06/bin/java 
  • Modificare il file /etc/eclipse/java_home. Il file è un elenco di virtual machine compatibili e da questo viene presa la prima virtual machine disponibile sul sistema. E' sufficiente ordinare questo affinché venga utilizzata la virtual machine preferita. Ad esempio per Sun Java 6 aggiungere la voce /usr/lib/jvm/java-6-sun.

Java JRE

Per i programmi avviati da GIJ vengono usate le librerie della GNU classpath. Se invece si desidera utilizzare Sun Java, si deve andare ad aggiungerlo su Window → Preferences... → Java → Installed JREs. Come la "JRE home directory" deve essere /usr/lib/jvm/java-1.5.0-sun-1.5.0.06 (la versione deve adattata a quella in uso). In aggiunta sotto "JRE system libraries" bisogna impostare le librerie di Sun Java che si trovano nella cartella /usr/lib/jvm/java-1.5.0-sun-1.5.0.06/jre/lib ( la versione deve essere adattata)

Uso di Junit4

Junit è incluso fra le versioni disponibili nelle sorgenti solo alla versione 4. Se si desidera utilizzare Junit 4 seguire il paragrafo Installazione manuale.

Compatibilità con Windows

Quando si passano da Windows a Ubuntu i propri progetti di Eclipse si ha il problema che le modifiche al codice del codice sorgente come caratteri accentati non vengano visualizzati correttamente. Per prevenire ciò, dovrebbe essere cambiata in Eclipse sotto Windows la codifica del testo da Cp1252 a UTF-8 per creare tuuti i nuovi progetti con questa codifica del testo. Un 100 % di compatibilità Windows-Ubuntu è assicurata con Eclipse.

Le appropriate impostazioni è possibile trovarle nel menù principale di Eclipse sotto Window → Preferences → General → Workspace nella finestra "File encoding" ce n'è una per la codifica di testo da CP1252 a UTF-8. Questa è l'unica cosa da fare prima di creare un nuovo progetto.

Se si hanno progetti con codifica di testo Cp1252 con iconv o recode, la codifica verrà successivamente cambiata in UTF-8. Il comando iconv è:

iconv --from-code=WINDOWS-1252 --to-code=UTF8  xxx.java 

Ulteriori risorse


CategoryProgrammazione CategoryDaRevisionare