Wiki Ubuntu-it

Indice
Partecipa
FAQ
Wiki Blog
------------------
Ubuntu-it.org
Forum
Chiedi
Chat
Cerca
Planet
  • Immutable Page
  • Info
  • Attachments

Revision 3 as of 30/03/2009 15.26.48

Clear message

BR Indice()

Introduzione

OpenOffice.org è una suite per ufficio multipiattaforma e multilingua compatibile con le principali suite per ufficio, commerciali e non.

OpenOffice.org

Questa suite è divisa in diversi moduli che possono interagire tra di loro:

  • Writer: word processor

  • Calc: foglio di calcolo

  • Impress: presentazioni

  • Draw: disegno

  • Base: database

  • Math: editor di formule

È possibile inoltre esportare i documenti realizzati in formato PDF

Installazione

Versione 2.4

Per installare la suite, anche se risulta già installata in modo predefinito, è sufficiente [:AmministrazioneSistema/InstallareProgrammi:installare] il pacchetto openoffice.org.

Con Xubuntu, invece, non tutti i moduli risultano presenti e nel caso di necessità bisogna installare i pacchetti corrispondenti.

Immagine(Icone/Piccole/warning.png,,center)

Se OpenOffice.org si chiude all'apertura di un documento *.swx o lanciando l'assistente, controllare che sia installato il pacchetto openoffice-base.

Versione 3.0.1

Aggiungere i seguenti repository per Hardy

deb http://ppa.launchpad.net/openoffice-pkgs/ubuntu hardy main
deb-src http://ppa.launchpad.net/openoffice-pkgs/ubuntu hardy main

Oppure per Intrepid

deb http://ppa.launchpad.net/openoffice-pkgs/ubuntu intrepid main
deb-src http://ppa.launchpad.net/openoffice-pkgs/ubuntu intrepid main

E autenticare la seguente chiave gpg:

gpg --keyserver keyserver.ubuntu.com --recv 60D11217247D1CFF
gpg --export --armor 60D11217247D1CFF | sudo apt-key add -

Installare il dizionario italiano

Consultare la [:/Dizionario:relativa guida].

Aggiungere una collezione di clipart

Per aggiungere una collezione di clipart in OpenOffice.org è sufficiente installare il pacchetto openclipart.

Una volta installato tale pacchetto selezionare, fare clic su Strumenti -> Gallery. Sselezionare quindi l'immagine desiderata e col tasto destro del mouse scegliere tra le varie opzioni che appariranno nel menù a discesa.

Risoluzione dei problemi

Problemi con Java su Ubuntu 6.06 «Dapper Drake»

Per ovviare ai problemi riscontrabili nell'utilizzo delle applet Java, è necessario [:AmministrazioneSistema/InstallareProgrammi:installare] il pacchetto j2re1.4, presente nel [:Repository/Componenti:componente] multiverse dei [:Repository:repository] ufficiali e configurare l'ambiente Java utilizzato da OpenOffice.org.

Per fare ciò, dopo aver installato il sopracitato pacchetto, fare clic su Strumenti -> Opzioni -> Java e scegliere l'opzione «BlackDown Java-linux Team».

Supporto ai documenti Office Open XML

Consultare la [:/OdfConverter:relativa guida].

Configurazione

Impostazioni lingua

Per modificare la lingua utilizzata in OpenOffice.org le possibilità sono diverse:

  • Utilizzo del menù stesso di OpenOffice.org Strumenti->Opzioni->Impostazioni Lingua.

  • Oppure, se vi è bisogno di realizzare un controllo ortografico di un solo paragrafo o di un intero testo, selezionarlo, aprire il menu contestuale (click tasto destro) e scegliere modifica modello paragrafo -> Carattere e selezionare dal menu a tendina « lingua » l'impostazione voluta.

  • Altrimenti dal menu principale Formato -> Carattere e selezionare l'impostazione preferita come al punto precedente.

Accelerare l'avvio

Per velocizzare l'avvio di OpenOffice.org è possibile modificare alcuni parametri nello stesso programma:

  • Aprite OpenOffice.org e dal menù in alto selezionate Strumenti -> Opzioni

  • Selezionate Memoria principale e aumentate, in funzione della memoria posseduta, le seguenti opzioni:

    • « Cache grafica »
    • « Memoria per oggetto »
  • Inoltre è possibile , attraverso « Numero di operazioni », regolare il numero di Operazioni in memoria, ovvero quante modifiche possono essere memorizzate di modo tale che attraverso l'opzione Annulla si possano rimuovere, riducendole, le prestazioni possono migliorare
  • Selezionare « Abilita QuickStart sulla barra delle applicazioni »

  • Portarsi nella scheda Java e disabilitare « Usa un ambiente runtime Java »

Problemi

  • In Xubuntu l'opzione è disabilitata : per aver accesso a questa opzione dovete installare il pacchetto openoffice.org2-gnome, riavviando OpenOffice.org l'opzione sarà abilitata.

Guide specifiche

Ulteriori risorse