Wiki Ubuntu-it

Indice
Partecipa
FAQ
Wiki Blog
------------------
Ubuntu-it.org
Forum
Chiedi
Chat
Cerca
Planet
  • Immutable Page
  • Info
  • Attachments
  • Diff for "domi84/Prove1"
Differences between revisions 2 and 3
Revision 2 as of 09/03/2009 21.41.52
Size: 2012
Editor: Alberto
Comment: CategoryHomepage
Revision 3 as of 30/03/2009 15.26.48
Size: 5524
Editor: domi84
Comment:
Deletions are marked like this. Additions are marked like this.
Line 2: Line 2:
#language it #LANGUAGE it
Line 4: Line 4:
[[Indice]]
[[Indice()]]
Line 8: Line 7:
In questa guida sono presenti delle istruzioni utili per montare la memoria di un cellulare all'interno di '''Ubuntu'''. '''Open``Office.org''' è una suite per ufficio multipiattaforma e multilingua compatibile con le principali suite per ufficio, commerciali e non.
Line 10: Line 9:
= Preparativi =
Per verificare che la periferica bluetooth sia configurata correttamente, consultare la [:Hardware/DispositiviSenzaFili/Bluetooth:relativa guida].
== OpenOffice.org ==

Questa suite è divisa in diversi moduli che possono interagire tra di loro:

    * '''Writer''': word processor
    * '''Calc''': foglio di calcolo
    * '''Impress''': presentazioni
    * '''Draw''': disegno
    * '''Base''': database
    * '''Math''': editor di formule

È possibile inoltre esportare i documenti realizzati in formato PDF
Line 15: Line 24:
[:AmministrazioneSistema/InstallareProgrammi:Installare] i seguenti pacchetti reperibili dai [:Repository:repository ufficiali]: == Versione 2.4 ==
Line 17: Line 26:
  * ''bluetooth''
  * ''bluez-gnome''
  * ''bluez-utils''
  * ''gnome-bluetooth''
  * ''gnome-vfs-obexftp''
  * ''obexfs''
Per installare la suite, anche se risulta già installata in modo predefinito, è sufficiente [:AmministrazioneSistema/InstallareProgrammi:installare] il pacchetto ''openoffice.org''.

Con '''Xubuntu''', invece, non tutti i moduli risultano presenti e nel caso di necessità bisogna installare i pacchetti corrispondenti.

||<tablestyle="text-align: justify; width:100%; " style="border:none;" 5%>[[Immagine(Icone/Piccole/warning.png,,center)]] ||<style="padding:0.5em; border:none;">'''Se Open``Office.org si chiude all'apertura di un documento `*.swx` o lanciando l'assistente, controllare che sia installato il pacchetto''' ''openoffice-base''. ||

== Versione 3.0.1 ==
Aggiungere i seguenti repository per Hardy
{{{
deb http://ppa.launchpad.net/openoffice-pkgs/ubuntu hardy main
deb-src http://ppa.launchpad.net/openoffice-pkgs/ubuntu hardy main
}}}

Oppure per Intrepid
{{{
deb http://ppa.launchpad.net/openoffice-pkgs/ubuntu intrepid main
deb-src http://ppa.launchpad.net/openoffice-pkgs/ubuntu intrepid main
}}}

E autenticare la seguente chiave gpg:
{{{
gpg --keyserver keyserver.ubuntu.com --recv 60D11217247D1CFF
gpg --export --armor 60D11217247D1CFF | sudo apt-key add -
}}}

= Installare il dizionario italiano =

Consultare la [:/Dizionario:relativa guida].

= Aggiungere una collezione di clipart =

Per aggiungere una collezione di clipart in '''Open``Office.org''' è sufficiente installare il pacchetto ''openclipart''.

Una volta installato tale pacchetto selezionare, fare clic su '''''Strumenti -> Gallery'''''. Sselezionare quindi l'immagine desiderata e col tasto destro del mouse scegliere tra le varie opzioni che appariranno nel menù a discesa.

= Risoluzione dei problemi =

== Problemi con Java su Ubuntu 6.06 «Dapper Drake» ==

Per ovviare ai problemi riscontrabili nell'utilizzo delle applet Java, è necessario [:AmministrazioneSistema/InstallareProgrammi:installare] il pacchetto ''j2re1.4'', presente nel [:Repository/Componenti:componente] '''multiverse''' dei [:Repository:repository] ufficiali e configurare l'ambiente Java utilizzato da '''!OpenOffice.org'''.

Per fare ciò, dopo aver installato il sopracitato pacchetto, fare clic su '''''Strumenti -> Opzioni -> Java''''' e scegliere l'opzione «'''Black``Down Java-linux Team'''».
Line 25: Line 70:
= Avvio = == Supporto ai documenti Office Open XML ==
Line 27: Line 72:
Per avviare l'applet premere la seguente combinazione di tasti '''ALT + F2''' e digitare il seguente comando:{{{
bluetooth-applet
}}}
Consultare la [:/OdfConverter:relativa guida].
Line 31: Line 74:
= Utilizzo = = Configurazione =
== Impostazioni lingua ==
Line 33: Line 77:
Per modificare la lingua utilizzata in '''Open``Office.org''' le possibilità sono diverse:
Line 34: Line 79:
||<tablestyle="width:100%; margin:10px 0 5px 0;" style="border:none;" 40% : >[[Immagine(Hardware/DispositiviPartizioni/MontareTelefonoCellulare/esplora.png,300,center)]] ||<style="border:none;">Per accedere al proprio dispositivo andare nel gestore bluetooth sulla barra della scrivania e selezionare con il tasto destro la voce «'''esplora dispositivo...'''». ||   * Utilizzo del menù stesso di '''Open``Office.org''' '''''Strumenti->Opzioni->Impostazioni Lingua'''''.
  * Oppure, se vi è bisogno di realizzare un controllo ortografico di un solo paragrafo o di un intero testo, selezionarlo, aprire il menu contestuale (click tasto destro) e scegliere '''''modifica modello paragrafo -> Carattere''''' e selezionare dal menu a tendina « lingua » l'impostazione voluta.
  * Altrimenti dal menu principale '''''Formato -> Carattere''''' e selezionare l'impostazione preferita come al punto precedente.
Line 36: Line 83:
||<tablestyle="width:100%; margin:10px 0 5px 0;" style="border:none;" 40% : >[[Immagine(Hardware/DispositiviPartizioni/MontareTelefonoCellulare/visualizza.png,450,center)]] ||<style="border:none;">Verrà visualizzata una finestra con tutti i dispositivi bluetooth trovati durante la scansione; connettersi al dispositivo desiderato. || == Accelerare l'avvio ==
Line 38: Line 85:
||<tablestyle="width:100%; margin:10px 0 5px 0;" style="border:none;" 40% : >[[Immagine(Hardware/DispositiviPartizioni/MontareTelefonoCellulare/cartelle.png,450,center)]] ||<style="border:none;">Verrà richiesta una conferma di sicurezza sul cellulare, una volta accettata verranno visualizzati i dischi. || Per velocizzare l'avvio di '''Open``Office.org''' è possibile modificare alcuni parametri nello stesso programma:

 * Aprite '''Open``Office.org''' e dal menù in alto selezionate '''''Strumenti -> Opzioni'''''
 * Selezionate '''''Memoria principale''''' e aumentate, in funzione della memoria posseduta, le seguenti opzioni:
   * « Cache grafica »
   * « Memoria per oggetto »
 * Inoltre è possibile , attraverso « Numero di operazioni », regolare il numero di Operazioni in memoria, ovvero quante modifiche possono essere memorizzate di modo tale che attraverso l'opzione Annulla si possano rimuovere, riducendole, le prestazioni possono migliorare
 * Selezionare « Abilita Quick``Start sulla barra delle applicazioni »
 * Portarsi nella scheda '''''Java''''' e disabilitare « Usa un ambiente runtime Java »

=== Problemi ===

  * In Xubuntu l'opzione è disabilitata : per aver accesso a questa opzione dovete installare il pacchetto ''openoffice.org2-gnome'', riavviando '''Open``Office.org''' l'opzione sarà abilitata.

= Guide specifiche =

 * [:/FileAccess:Operare su database di Access con OpenOffice.org]
 * [:Server/MySql/OpenOfficeOdbc:Guida all'uso di OpenOffice.org con MySql]
 * [:/OdfConverter:Supporto ai documenti Office Open XML]
 * [:/Dizionario:Installare il dizionario italiano]
 * [http://www.galileicrema.it/intraitis/Documenti/MaterialeDidattico/appuntiCalc_base.pdf Approfondimenti su Calc]
Line 42: Line 109:
 * [http://alexit.wordpress.com/2007/11/21/esplorare-lo-smartphone-come-un-disco-esterno-in-2-click/ Documento originale]  * [http://it.openoffice.org/ Sito ufficiale del progetto]
 * [http://en.wikipedia.org/wiki/Office_Open_XML Documenti Office Open XML]
 * [http://www.gnome-look.org/content/show.php/LiNsta+3+%28Linux+is+Not+Vista%29?content=44570 Tema Linsta3 per GNOME]
Line 44: Line 114:
CategoryHomepage

BR Indice()

Introduzione

OpenOffice.org è una suite per ufficio multipiattaforma e multilingua compatibile con le principali suite per ufficio, commerciali e non.

OpenOffice.org

Questa suite è divisa in diversi moduli che possono interagire tra di loro:

  • Writer: word processor

  • Calc: foglio di calcolo

  • Impress: presentazioni

  • Draw: disegno

  • Base: database

  • Math: editor di formule

È possibile inoltre esportare i documenti realizzati in formato PDF

Installazione

Versione 2.4

Per installare la suite, anche se risulta già installata in modo predefinito, è sufficiente [:AmministrazioneSistema/InstallareProgrammi:installare] il pacchetto openoffice.org.

Con Xubuntu, invece, non tutti i moduli risultano presenti e nel caso di necessità bisogna installare i pacchetti corrispondenti.

Immagine(Icone/Piccole/warning.png,,center)

Se OpenOffice.org si chiude all'apertura di un documento *.swx o lanciando l'assistente, controllare che sia installato il pacchetto openoffice-base.

Versione 3.0.1

Aggiungere i seguenti repository per Hardy

deb http://ppa.launchpad.net/openoffice-pkgs/ubuntu hardy main
deb-src http://ppa.launchpad.net/openoffice-pkgs/ubuntu hardy main

Oppure per Intrepid

deb http://ppa.launchpad.net/openoffice-pkgs/ubuntu intrepid main
deb-src http://ppa.launchpad.net/openoffice-pkgs/ubuntu intrepid main

E autenticare la seguente chiave gpg:

gpg --keyserver keyserver.ubuntu.com --recv 60D11217247D1CFF
gpg --export --armor 60D11217247D1CFF | sudo apt-key add -

Installare il dizionario italiano

Consultare la [:/Dizionario:relativa guida].

Aggiungere una collezione di clipart

Per aggiungere una collezione di clipart in OpenOffice.org è sufficiente installare il pacchetto openclipart.

Una volta installato tale pacchetto selezionare, fare clic su Strumenti -> Gallery. Sselezionare quindi l'immagine desiderata e col tasto destro del mouse scegliere tra le varie opzioni che appariranno nel menù a discesa.

Risoluzione dei problemi

Problemi con Java su Ubuntu 6.06 «Dapper Drake»

Per ovviare ai problemi riscontrabili nell'utilizzo delle applet Java, è necessario [:AmministrazioneSistema/InstallareProgrammi:installare] il pacchetto j2re1.4, presente nel [:Repository/Componenti:componente] multiverse dei [:Repository:repository] ufficiali e configurare l'ambiente Java utilizzato da OpenOffice.org.

Per fare ciò, dopo aver installato il sopracitato pacchetto, fare clic su Strumenti -> Opzioni -> Java e scegliere l'opzione «BlackDown Java-linux Team».

Supporto ai documenti Office Open XML

Consultare la [:/OdfConverter:relativa guida].

Configurazione

Impostazioni lingua

Per modificare la lingua utilizzata in OpenOffice.org le possibilità sono diverse:

  • Utilizzo del menù stesso di OpenOffice.org Strumenti->Opzioni->Impostazioni Lingua.

  • Oppure, se vi è bisogno di realizzare un controllo ortografico di un solo paragrafo o di un intero testo, selezionarlo, aprire il menu contestuale (click tasto destro) e scegliere modifica modello paragrafo -> Carattere e selezionare dal menu a tendina « lingua » l'impostazione voluta.

  • Altrimenti dal menu principale Formato -> Carattere e selezionare l'impostazione preferita come al punto precedente.

Accelerare l'avvio

Per velocizzare l'avvio di OpenOffice.org è possibile modificare alcuni parametri nello stesso programma:

  • Aprite OpenOffice.org e dal menù in alto selezionate Strumenti -> Opzioni

  • Selezionate Memoria principale e aumentate, in funzione della memoria posseduta, le seguenti opzioni:

    • « Cache grafica »
    • « Memoria per oggetto »
  • Inoltre è possibile , attraverso « Numero di operazioni », regolare il numero di Operazioni in memoria, ovvero quante modifiche possono essere memorizzate di modo tale che attraverso l'opzione Annulla si possano rimuovere, riducendole, le prestazioni possono migliorare
  • Selezionare « Abilita QuickStart sulla barra delle applicazioni »

  • Portarsi nella scheda Java e disabilitare « Usa un ambiente runtime Java »

Problemi

  • In Xubuntu l'opzione è disabilitata : per aver accesso a questa opzione dovete installare il pacchetto openoffice.org2-gnome, riavviando OpenOffice.org l'opzione sarà abilitata.

Guide specifiche

Ulteriori risorse