Wiki Ubuntu-it

Indice
Partecipa
FAQ
Wiki Blog
------------------
Ubuntu-it.org
Forum
Chiedi
Chat
Cerca
Planet
  • Immutable Page
  • Info
  • Attachments


Introduzione

Questa una mini guida per l'uso basilare di Qcad, un ottimo CAD professionale per Linux e per la successiva importazione e lavorazione dei dati in Grafica/Blender, che serve a creare modelli 3D, ad animarli e creare il redering. Qcad è con la versione in licenza GPL "Comunity" è liberamente usabile senza pagare alcun che ... ,mentre più sviluppato ,aggiornato e a pagamento la versione "Professional" la quale ha il prezzo base di " 25 Euro " dal sito ufficiale Qcad,

QCAD

Installazione

Per installare QCad "Comunity" è sufficiente Attivare le componente Repository/Componenti#main e Repository/Componenti#universedei repository ufficiali di Ubuntu.

Per prima cosa è consigliabile installare partlibrary

sudo apt-get install partlibrary 

che aggiunge le librerie con file preimpostati (disegni di vasche da bagno, finestre, lampade...).

Installazione di QCAD:

sudo atp-get install qcad

Per lanciare Qcad digitare nel terminale

qcad

Uso di QCAD

  • creare librerie personalizzate: disegni standard (per esempio, vasche da bagno, tavoli, finestre ecc...) possono essere salvati come librerie e riusate per altri progetti. Per fare ciò i disegni devono essere salvati in una della cartelle (o creare una cartella nuova per salvarvi dentro) in /usr/share/qcad/libraries,stessa cosa per il tratteggio in /usr/share/qcad/patterns e altri percorsi come i font ecc... che sono visionabili in Edit ->Application preferences -> paths ;le nuove librerie aggiunte possono essere inserite tramite il pannello Library Browser. Per visualizzare tale pannello bisogna cliccare in View -> Views -> Library Browser.

  • Livelli (layer): tutti gli oggetti appartenenti ad un layer possono essere modificati negli attributi contemporaneamente . Bisogna innanzitutto selezionare il layer che ci interessa prima di tracciare ,assicurarsi che ogni sezione degli attributi colore,linea ,tratto abbia la sigla "Da Layer",in caso di volere cambiare attributo ad un qualcosa già tracciato la si selezione si va in Edit ->Edit entity attribute(si trova nel pannello laterale),oppure in Modify -> Attribute .Se si modifica gli attributi di un layer tutte le linee influenzate dallo stesso subiscono il cambiamento.

  • L'opzione Blocco è utile non solo all'interno di Qcad ma anche per importazione di Blender. Questa opzione consente di ordinare un disegno in diversi gruppi (anzi se si salvano i file DXF con blocchi nelle libreria quando si inserisce ,essi vengono inseriti ...) Per creare un blocco basta premere nella barra laterale sinistra il pulsante con il simbolo +, Crea Blocco. Scrivere il nome e premere OK .il blocco non rende lavorabile,per poterci lavorare come semplice disegno basta andare nella barra menù in "Modify -> Explode" oppure al pannello laterale in "Edit->Explode"

Blender

Installazione

Blender è disponibile nella sezione universe dei repository ufficiali. Una volta attivati tali repository e aggiornato con il comando

sudo apt-get update

è sufficiente dare il comando

sudo apt-get install blender

Blender si lancia con il seguente comando

blender

Importazione dei file DXF in Blender

Il progetto in QCAD sarà stato salvato con estensione DXF, il formato nativo di QCAD. Blender ha vari script per vari formati di importazione, in questa guida viene trattato lo script autodesk:

File -> Import -> Autodesk DXF

Il pannello di importazione è molto intuitivo: si seleziona il file in questione e si clicca start import. Una volta terminata l'importazione si clicchi exit, tornando così alla vista 3D iniziale, nell'importazione i "Blocchi" che si avevano divengono in Blender "Gruppi"che sono raggiungibili da vista User preference in Add > Group ...

Modificare i dati importati

Per poter lavorare al meglio il nostro file abbiamo bisogno anche della vista Outliner, dividiamo quindi la finestra in due, in modo da avere due viste contemporaneamente: Posizionando il cursore del mouse al bordo destro o sinistro della finestra,al superiore o inferiore il cursore diventerà una freccia a due punte. Cliccare con il tasto destro e scegliere split area.

In una delle due finestre create possiamo adesso selezionare la vista Outliner, cliccando sull'icona col la griglia in basso a sinistra: display current window -> outliner. In questa vista possiamo vedere i blocchi del file appena importato e selezionarli.

I blocchi non saranno però lavorabili. Per rendere lavorabile un blocco bisogna selezionarlo il outliner, poi in vista 3D cliccare Object -> Clear/Apply -> Make Duplicates Real. Adesso si può cliccare sul menù a tendina in basso e cambiare da Object Mode a Edit Mode.

Il blocco selezionato sarà ora lavorabile e ne saranno ora visibili i vertici. È possibile che l'oggetto sia stato importato diviso in diverse parti. Le parti possono essere unite selezionandole tutte (click + shift) e premendo la combinazione di tasti Ctrl+j. Se si desidera selezionare i vertici , si possono selezionare i vertici premendo buna volta per una selezione rettangolare e 2 volte per il pennello selezione di cui la dimensione cambia o con la rotellina del mouse oppure con Pag su e Pag giù ,inoltre con Ctrl premuto si ha la selezione libera ,in qualsiasi modalità di selezione che si scelga con il tasto sinistro del mouse premuto e trascinato si seleziona mentre con il tasto centrale del mouse si annulla la selezione. Con il tasto P si separano le parti selezionate dalle altre.

Per unire i vertici in una costruzione si selezionano per lo meno 2 e si preme Alt+M ,per unire i vertici sovrapposti d si prema il tasto A per selezionare tutto e poi il tasto F9 si giunge al pannello Mesh tools in basso al centro, si clicchi Rem Doubl per rimuovere i vertici sovrapposti. Nello stesso pannello dove si trova Rem Doubl si trova lo strumento Spin, per torneare l'oggetto e creare, per esempio, i vasi. Il procedimento è semplice.

Creare un Vaso

Una volta creato il profilo del nostro vaso, si faccia coincidere il cursore con il suo centro, poi si scegli una visuale dall'alto e si impostino i gradi...

Importare in Blender da Blend

Blender permette di importare file anche da altri file .blend con lo strumento file -> Append or Link Schift+F1). L'importazione da file .blend permette a Blender di poter usare questi come una libreria un pò come succede in Qcad, è quindi utile per tavoli e vasi da conservare, water e lavabo,ringhiere divise in pezzi dritti e angolari da poter montare in seguito e cosi via ....

Altri comandi

  • Alt+M unisce i vertici

  • V separa i vertici

  • Schift + D duplica

  • Alt + D duplica collegato

  • CTRL + Z torna indietro di una passo

  • Schift + CTRL + Z torna avanti di una passo

  • F12 crea il redering e F3 lo salva

  • F crea le facce

  • Schift+F crea le facce a più vertici e lati

  • C centra la vista al cursore

  • + e - zoom avanti e indietro dell'oggetto selezionato.

  • N richiama le proprietà delle Mesh (si possono cambiare le misure di altezza e lunghezza, scala ,posizione ,rotazione ecc...

  • K crea dei tagli e con l'ausilio di " Ctrl " si posizionano sui vertici ,,,

Ulteriori risorse


CategoryHomepage